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Creating your own 
Vegetation Symbol

KeyTREE provides you with the facility to quickly create and add new symbols to the 
system, allowing you to develop your own graphic style for your drawings. You can add 
graphics to the specific symbol types, e.g. trees, shrubs, etc, to expand the default 
palettes. Also, KeyTREE includes three blank Project Symbol libraries where you can add, 
and quickly retrieve, your own preferred graphics, such as standard drawings. 

Drawing the 
Symbol

• From the File menu select New to start a new (Blank) drawing based on the 
ACADISO.dwt (AutoCAD metric) template or KSLTOSO.dwt (KeySCAPE LT 
metric) template.

• From the Draw pulldown menu, select Circle>Centre, Radius

• When requested at the command prompt to Specify center point for circle, 
enter 0,0.

This will put the centre of the circle at the co-ordinate 0,0, the insertion reference point 
used when it is inserted in a KeyTREE drawing later.

• When  requested  at  the  command  prompt  to  Specify  radius  of  circle  or 
[Diameter], enter (a radius of) 0.5.

This will create a 1 unit diameter circle. This means that when it is inserted in to a drawing, 
you can define the spread of the vegetation drawing and the symbol will scale correctly.

• From  View>Zoom menu select  Extents. The circle will now fill  the drawing 
editor. 

If the circle looks angular, from View menu select  Regen to refresh the display 
and smooth the circle.

• From  Format>Layer,  create  a new layer  called  T_plan_01 and assign the 
colour 64, or other required, to the new layer. 

• Make the layer T_plan_01 Current. Pick [OK].

• Create, using AutoCAD’s drawing tools, your own unique vegetation drawing 
using the construction circle as a guide, e.g. 

• Once the symbol id defined, erase the construction circle used to define the 
drawing extents.

• From View>Zoom select Extents. The symbol will now fill the drawing editor.

• When you have created your symbol, select  File>Save  and navigate to the 
directory:
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C:\KeySCAPE Systems Application Data\
      All Users\
            KeyCORE\
                  Symbols\
                          Project 1\

                                          Plan\
                                  Vegetation

• For the drawing name, enter  Mytree, or other name as required, and select 
Save. Close the drawing

• The vegetation symbol will be added to the Tree Symbols Library.

Using your New 
Symbol

• Open the drawing into which you wish to insert the new symbol.

• From Tree, select Project Libraries>Project 1. The Project 1 dialog appears.

• Select the Plan tab to display your plan symbol.

• Double-click the image icon. You are returned to the drawing editor.

• At the command line you are prompted:

Insertion Point: (Pick the insertion point of the tree)
Spread: (Enter the spread of the tree)
Height: (Enter the height of the tree)
Rotation: (Enter the rotation for the tree)

• The vegetation symbol you created will now appear in the drawing.

The symbol created will remain in the project library unless you choose to delete it using  
Windows Explorer. 

KeySCAPE contains  3 project  libraries.  These allow you to  create  and  add your  own 
graphics to the system to build up your own palette of symbols for quick access to your  
preferred symbols. These can be accessed, as described above, or by using the shortcut  
keys:

P1 - Project 1

P2 - Project 2

P3 - Project 3

Creating your own 
Vegetation Edge 

Pattern

KeyTREE now provides you with the facility to quickly create and add new line patterns for 
use with the display of the tree canopy (when not using Use BS Category), allowing you to 
develop your own graphic style for your drawings. 

Drawing the Pattern

• From the File menu select New to start a new (Blank) drawing based on the 
ACADISO.dwt (AutoCAD metric) template or KSLTISO.dwt (KeySCAPE LT 
metric) template.

• From the Draw pulldown menu, select Line.
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• When requested at the command prompt to Specify first point: pick a point 
on the screen where you wish to start drawing the line.  This point does not 
need to be 0,0.

• When requested at the command prompt to  Specify next point or [Undo]: 
enter @1,0. and press Return. This will draw a construction line 1 unit in the X 
and 0 in the Y.

• Press Return to complete the line command.

• From View>Zoom, select Extents. The line will now fill the drawing editor.

• This  (construction) line will  provide a template that ensures that the pattern 
scale and start point is set correctly.

• Create a new layer, e.g. KST_PATTERN_01 and make the new layer Current. 

• Pick [OK].

IMPORTANT –  Patterns MUST be drawn in metres, fit within 1 drawing unit, and must  
comprise of only polylines or arc-segmented polylines but NOT arcs, lines or circles. 

• From the Draw toolbar, select Polyline.

• Using  the  construction  line  as  a  guide,  draw the  required  pattern  so  that 
polyline fits between the start and endpoints of the line.

The pattern can be created from several polylines. These polylines do not need to start 
and end on the endpoints of the construction line but this will create gaps in the graphics 
when used later in the drawing.

• When the pattern is complete, you can convert it into a new pattern. 
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Converting the Drawing into a Pattern

• From the Tree pulldown menu, select Pattern Manager. The Pattern 
Manager dialog will appear. 

• Pick [New]. You are returned to the drawing.

• At the command line prompt to Select Objects: pick the polylines that defines 
the pattern, excluding the contraction line, although this should be filtered out, 
as it is a line not a polyline.

• At  the command line prompt  to  Select  Pattern  Origin:,  using the OSNAP 
Endpoint, pick the end of the line at the start of the pattern (furthest left). The 
Pattern Name dialog appears. 

You do not need to define the other end of the pattern as KeySCAPE assumes the length  
of the pattern is I unit, hence the purpose of the original construction line.

• Enter a new name for the pattern, e.g. KST Pattern.

• Pick [OK]. The Pattern Manager dialog will reappear and the pattern will be 
displayed in the list.

• Pick [Finished] to complete the creation of the pattern. 
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Using your New Pattern

• Add a new tree using Quick Add and Add or edit an existing tree using Modify 
(see Section 1 for information on creating and modifying survey Trees).The relevant 
Add or Modify dialog appears

• Pick [Display Options] The Tree Display Options dialog appears. 
• Select the Canopy Options tab. This offers options to control to control the display 

of the canopy 

• Un-check Use B.S. Category. This opens several edit windows that are not 
available when using BS colour systems

• Under Draw Mode, pick Pattern from the dropdown list
• Under Pattern, pick the new or any predefined pattern from the dropdown list
• Define the display of the based on:

Draw Base Geometry – Sets whether  or not the canopy base line draws
Alignment - The side of the base line where the pattern ise drawn 
Flip Pattern - Flip the orientation of the pattern 
X Scale - The scale of the pattern in the X-axis
Y Scale - The scale of the pattern in the Y-axis 
Offset – Sets the offset distance from the base line 

To Preview your changes pick [OK] and then pick [Preview] in the main dialog. Return to 
the Display Options dialog to make further changes or to finalise your settings
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• When your pattern is defined, either pick [OK] to set this display option for this 
tree alone or [Set Defaults] if you wish this to be the default for any new tree 
inserted into the current drawing.

• Pick [OK] to close the main Add or Modify dialog

Managing the 
KeyTREE 
Database

KeyTREE uses the following databases to store default data::

KSW_Database.mdb (Softworks) – Species Name, Common Name and 
Abbreviation

KSS_Database.mdb (Site Survey)  – Tree Survey and TPO data, such as BS Categories, 
Estimated Remaining Contribution, Age Class, Physiological Condition, etc.

Unless defined elsewhere during installation, ore redefined after installation, these 
databases are typically is typically installed and located in the folder:

C:\KeySCAPE Systems Application Data 10.7\All Users\KeySOFTWORKS\Database

and 

C:\KeySCAPE Systems Application Data 10.7\All Users\KeySITESURVEY\Database

Backing Up your Database
As the  databases  contains  all  your  customised  information,  you  are  recommended  to  
regularly back these up or move the default location to a network location where it should  
be backed up on a regular basis and can be shared by other KeyTREE (and KeySCAPE)  
users. 
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Database Location 
and Sharing

To share the KeyTREE databases between users they should be located on the network 
and each PC should then be configured look in this location.

Moving Your Databases to a Network Location

• Log in on to the current computer as a  local administrator or a user with 
local administrator permissions, this needs to be a local not domain administrator.

• Open Windows Explorer.

• Copy the KeySCAPE Systems Application Data folder and all sub folders to 
a network location.

Pointing KeyTREE to Use the Network Databases

• From the Start>Programs>KeySCAPE Systems, run Configure KeySCAPE 
for your application. The Configure KeySCAPE dialog appears

• Under Application Options, pick [Set App. Data Root Dir]. The Browse for 
Folder dialog appears. 
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• Browse to and select the network location where you copied your KeySCAPE 
Systems Application Data folder. 

• Pick [OK] to return to the Configure dialog.

• Pick [OK] to apply the change.

• Reopen KeyTREE/KeySCAPE

Setting Users to Use the Network Databases

• If  you  set  KeyTREE/KeySCAPE to  use  a  network  database  BEFORE the 
software is run for the first time by each user, on first run the network paths to 
the databases will be automatically reading from the administrator settings. 

• If  you  set  KeyTREE/KeySCAPE  to  use  a  network  database  AFTER the 
software is run for the first  time by each user it  will  default to the installed 
settings, typically C:\KeySCAPE Systems Application Data 10.7\All Users.

• To reset the user to use the network location, from Windows Start, select All 
Programs>  KeySCAPE  Systems>  KeySCAPE  (version  number)> 
Configure. The Configure dialog appears

• Pick [Reset Defaults]. This will reset the current settings to the administrator 
settings,  i.e. the network location. When this is completed successfully you will 
be notified. 

• Pick  [OK] to close the configure dialog. Run KeyTREE/KeySCAPE from the 
desktop icon and KeySCAPE should not run from the network databases. You 
can check this from Core>Configure

• Repeat this process for each user that has already run the software before you 
set the databases to to use the network locations

Whilst not recommended, you will note that flexibility exists to set different locations for 
individual folders contained within the KeySCAPE Systems Application Data folder. 
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Repairing and 
Compacting the 

Database

To maintain the performance of your database and repair any errors that may arise, it is 
recommended to compact and repair your database on a regular basis. 

• Close your copy of KeySCAPE / KeyTREE or, if sharing a network database, 
close all copies of KeySCAPE / KeyTREE.

• From  the  Windows  Desktop,  pick  Start>All  Programs>KeySCAPE 
Systems>Your  installed  application  (e.g.  KeySCAPE  Design  Studio 
2007)>Database Repair. The KeySCAPE Systems Database Repair dialog 
appears.

• If the path and database does not appear in the edit window, or is incorrectly 
defined, pick [Browse].

• Select the database from the list or pick  [Browse]  to navigate to and select 
your database file in the correct location. Pick [OK] to return to the KeySCAPE 
Systems Database Repair dialog

• Pick [Compact and Repair]. When complete you will be notified (this may 
take a few seconds to complete): 

• Close the dialogs and reopen KeySCAPE 

Modifying the 
Content of the 

Database

You can modify any data contained on the Softworks and Site Survey database at 
any time.

• From the TREE pulldown menu, select Database Manager. The Database 
Manager dialog appears. 

Adding or 
Modifying Plants 

in the Database

• From the Species tab, pick the dropdown under Choose Species Group. 
The Species group list appears.
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• From the list select the species group that contains the data you wish to 
modify, e.g. Trees. The edit window below will un-grey. 
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Adding a new species to the database

• Under the species list, pick [Modify]. A pop-up list will appear 

• Pick Add. The New Data dialog appears. 

• Enter the new species name. 
• Pick [OK] to add the new species to the species list for the currently selected 

group, e.g. Trees

Modifying a species name in the database

• Under the species list (left-hand side window) pick the plant you wish to 
modify and select [Modify]. From the pop-up list pick Edit. The Rename 
Species dialog appears. 
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• Enter the new name. Pick [OK] to apply the change 

Removing a Species

• Under the species list (left-hand side window) pick the plant you wish to 
remove and select [Modify]. From the pop-up list pick Delete. A warning 
dialog appears requiring you to confirm that you wish to delete the plant.

• Pick [Yes] or [No], as appropriate. 

Adding an Abbreviation and Common Name

• Under the species list (left-hand side window) pick the plant that you wish to 
add an abbreviation or common name. The right-hand windows will un-grey. 
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• Pick [Modify] under the appropriate window and the Add Abbreviation or 
Add common name will appear. 

• Enter the new data. Pick [OK] to assign the changes to the selected species.

You can assign multiple abbreviations and common names to a species and these can be  
selected when specifying the tree.

Editing an Abbreviation or Common Name assigned to a Species

• Under the species list (left-hand side window) pick the plant you wish to 
modify. The right-hand window will un-grey.

• Enter the new abbreviation or common name. Pick [OK] to update the data for 
the selected species. 

Removing an Abbreviation or Common Name assigned to a Species

• Under the species list (left-hand side window) pick the plant you wish to 
modify. The right-hand window will un-grey.
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• Under the abbreviation or common name list  (right-hand side window) pick 
[Modify]. From the pop-up list pick Delete. 

• A warning dialog appears requiring you to confirm that you wish to delete the 
data.

• Pick [Yes] or [No], as appropriate. 

Modifying Survey Lists on the Database
When specifying a tree you can select from common lists defined in KeyTREE. However, 
you can supplement these with your own specification items, if required. 

• From the Survey tab, pick the dropdown under Choose Survey Group. The 
Survey list appears.

• From the list select the group that contains the data you wish to modify, e.g. 
Structural Condition. The edit window below will un-grey.

• The data list will appear to show data that is available for editing within the 
selected group. 
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Adding a new Survey Group Item to the database

• Under the window, pick [Modify]. A pop-up list will appear

• Pick Add. The New Data Dialog appears.

• Enter the name for the new data, e.g. Very Poor. Pick [OK] to add the new 
data to the list. 

Editing a survey data Item

• Under the Survey Group list (top pop-down list) pick the category containing 
the item you wish to edit. The item will appear in the box below

• Pick the item you wish to modify from the list and pick [Modify]. From the pop-
up list pick Edit. The Rename dialog appears.

• Enter the new specification item. Pick [OK] to update the item for the selected 
category. 

Removing a Survey data Item

• Under the Survey Group list (top pop-down list) pick the category containing 
the item you wish to delete. The item will appear in the box below

• Pick the item you wish to delete from the list and pick [Modify]. From the pop-
up list pick Delete. 

• A warning dialog appears requiring you to confirm that you wish to delete the 
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item.

• Pick [Yes] or [No], as appropriate 

Specification 
Styles

Styles allow you to define or redefine the display of specification information in the 
drawing. Styles are a common means of displaying and modifying the appearance of an 
AutoCAD object in the drawing. You will be familiar with some of these using general  
AutoCAD, e.g. Text Styles, Dimension Styles, Plot Styles. 

AutoDesk has extended this functionality to control the display of objects in their own 
applications, such as Architectural Desktop, Map 3D and Civil Design. Styles allow you to 
quickly modify aspects of the object (or its display) and see the immediate affect of the 
change, not only to the main object but also to all "linked" objects, thus speeding up 
modifications to the drawing and the consideration of design options. KeyTREE uses 
Styles to control how information in a specification label or schedule is displayed. Drawing 
Setup (Core) allows you to create and define the default styles before you start drawing 
but you have the flexibility to create more styles and modify existing ones as you start  
designing. 

Modify the 
Appearance of 

Tree Specification 
Text

Also refer to Section 1: “Modifying a Tree Specification” for information regarding 
changing the Specification text font, height, angle (rotation) and redefining the specification 
leader.

• From the Tree drop-down, select Specification Display>Styles. The 
Specification Style dialog appears. 

• 

You can also access the specification styles from Core>Drawing Setup>Tree 
Styles (tab)>Specification Style> 

KeyTREE Tutorial 2-18
KeyTREE Section 2 Revision 1



Key Systems Advanced KeyTREE Features

You can modify the current style as follows:

• Style Name – drop down list showing the Specification Styles available in the 
current drawing. The default style, KeyTREE Standard will be created with 
every new drawing opened with KeyTREE

• [Rename...] - allows you to rename the currently selected Style

• [Copy Existing...] - allows you to make a copy of the currently selected Style 
and edit the display specification information so the original style remains 
unedited.

• [Delete...] - allows you to delete the currently selected Style from the drawing. 
You will not be able to delete a style if it is being used in the drawing·

• [Import...] & [Export...] - Specification Styles can be exported and imported 
as *.kis files. This provides the facility to export styles defined in one KeyTREE 
drawing to import in another KeyTREE drawing. If these files are held on a 
network, or shared drive, they can be used by several users, as required. 

The default KeyTREE Standard style will be created with every drawing opened with 
KeyTREE. If you wish to define your own default template, modify and export your 
preferred style overwriting the KeyTREE Standard.kis file. It is recommended that you 
make a copy of the original file before overwriting it in case you need to restore the default 
installed style in the future.

General / Leader 
Properties

General Settings

Cell Border Type - select from underline or box

Cell Background Colour – select from the full range of AutoCAD colours

Cell Border Colour – select from the full range of AutoCAD colours

Insertion Column – moves insertion point for text

Cell Margin – adjusts cell margins

Draw Empty Cells and Separator between Specifications can be set

Leader Properties

Point Type – select from blob, arrowhead etc.

Point Scale – adjust size of point

Colour - allows you to define the colour of the leader, as by default, the leader will 
take on the colour of the layer on which the object is inserted

Line-weight – select from line-weight

Endpoint – the end point of the leader can be set in relation to the text

Show Header At Leader Points – allows you to replace leader points with 
header text defined within the specification of the plant.

The Header at Leader Properties tab only appears if you have Show Header At 
Leader Points ticked on the General / Leader Properties tab. 
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Default Cell 
Properties

Text Style - pick from the list of current (AutoCAD) Text Styles defined in the 
drawing

Text Colour - select the preferred colour for the text as, by default, the text will 
take on the colour of the layer on which the object is inserted

Text Height - specify the height of the text relative to the current drawing units (M, 
MM or Inches)

Text Justification - defines whether the specification text is justified left, right or 
centred about the picked insertion point

Cell Border Type - select from underline or box

Cell Background Colour – select from the full range of AutoCAD colours

Cell Border Colour – select from the full range of AutoCAD colours

Cell Fixed Width – a fixed cell width ca be entered

Text Alignment – pick from the options: Top, Middle and bottom

Precision – Setting the precision here overrides the AutoCAD text precision 
setting

Selected Cell 
Properties

Selected Cell Properties

Text Style - pick from the list of current (AutoCAD) Text Styles defined in the 
drawing

Text Colour - select the preferred colour for the text as, by default, the text will 
take on the colour of the layer on which the object is inserted

Text Height - specify the height of the text relative to the current drawing units (M, 
MM or Inches)

Text Justification - defines whether the specification text is justified left, right or 
centred about the picked insertion point

Cell Border Type - select from underline or box

Cell Background Colour – select from the full range of AutoCAD colours

Cell Border Colour – select from the full range of AutoCAD colours

Cell Fixed Width – a fixed cell width can be entered
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Style Grid The grid displays the information that will be displayed in the drawing specification text. 

You can modify the grid in the following ways: 

[Insert] - Use the insert button to add new cells into the grid. First select the 
group and type of information to insert from the drop-downs. 
An item can only be inserted into the grid once. If the item is already in the grid it will no 
longer appear in the drop-down. If an item is removed from the grid it will re-appear in the 
drop-down. 

You can only add a specification item to a blank cell. If no cell is selected, the item will  
appear, by default, at the bottom of the list. If the selected cell already contains a 
specification item, you will be asked whether you wish to add it to the bottom of the list or 
not. If you select [No] the operation is cancelled. 

 Remove Data - select the specification item you wish to remove and pick 
the delete button from the navigation bar·

Navigation Buttons - use the appropriate buttons to 
define/redefine the position of a selected specification item 

within the grid, and thus its eventual display location in the drawing

You can select a currently occupied cell when inserting new data into the grid. If 
you do this you will be asked if you wish to overwrite the current cell or shift the 
current cell to the right or down.
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Assigning 
Specification 

Styles

When inserting a specification in the drawing the information will display according to the 
current style. However, you can have any number of styles available in a drawing and 
assign different styles to selected specifications, as required. You can assign a style to a 
specification, as follows: 

• From the TREE drop-down, select Specification Display>Set Style. You are 
returned to the drawing and prompted, at the command line, to select 
objects:

• Select the specifications you wish to assign a different style.

• When all required specifications are selected, press Return. The Set Style 
dialog will appear. 

• From the dropdown list, pick the specifications style you wish to apply to the 
selected specifications.

• Pick [OK] to assign the style. 

Schedules Styles The display of the Schedule is now defined using Styles. You can create and define the 
default style(s) used to display a schedule before you start drawing but you have the 
flexibility to create more styles and modify existing ones as you start designing.

To Modify the 
Appearance of a 

Schedule

• From the Tree drop-down, select Schedule Display>Styles. The 
Specification Style dialog appears.
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• You can also access schedule styles from Core>Drawing Setup>Softworks 
Styles (tab)>Schedule Style>  

You can modify the current style as follows:

• Style Name – drop down list showing the Schedule Styles available in the 
current drawing. The default style, KeyTREE Standard will be created with 
every new drawing opened with KeySCAPE·

• [Rename...] - allows you to rename the currently selected Style·

• [Copy Existing...] - allows you to make a copy of the currently selected Style 
and edit the display specification information so the original style remains 
unedited.·

• [Delete...] - allows you to delete the currently selected Style from the drawing. 
You will not be able to delete a style if it is being used in the drawing·

• [Import...] & [Export...] - Schedule Styles can be exported and imported as 
*.kss files. This provides the facility to export styles defined in one KeyTREE 
drawing to import in another KeyTREE drawing. If these files are held on a 
network, or shared drive, several users can use them, as required. 

The default KeyTREE Standard style will be created with every drawing opened with 
KeyTREE. To assist with the creation of schedule styles, KeyTREE includes plot schedules 
style that can be imported and modified, as required.

If you wish to define your own default template, modify and export your preferred style 
overwriting the KeyTREE Standard.kss file. It is recommended that you make a copy of the 
original file before overwriting it in case you need to restore the default installed style in the 
future.

Schedule Contents - allows you to specify the information to be displayed in the 
currently selected Style. This is controlled by the creation and modification of 
Groups (headings), which include Columns that define the information required 
to describe the object. In this way you can create different schedules that only 
show specific information, e.g. schedule only TPO information
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Defining Schedule Groups and Columns 

Construction of a Schedule

• [Add Group...] - creates a new group for the existing Style. This can be 
defined, as follows: 

• Header - The name of the group. This is what will appear in the “header” of 
the group when it appears in the schedule, e.g. Trees

•  Remove Data - select the specification item you wish to remove and 
pick the delete button from the navigation bar.

• Navigation Buttons - use the appropriate buttons to 
define/redefine the position of a selected specification item 

within the grid, and thus its eventual display location in the drawing

• Header - Text - The header text is entered when the Tree Schedule is added 
to the drawing:
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• Schedule Properties [Tabs] - allows you to specify the text and other settings 
for each part of the schedule, including: 

Style - pick from the list of current (AutoCAD) Text Styles defined in the drawing

Height - specify the height of the text relative to the current drawing units (m, mm 
or inches) Colour - select the preferred colour for the text as, by default, the text 
will use the colour of the layer on which the schedule is inserted

Border - specify whether the text is either: Boxed (has a frame), Not boxed (has 
no frame), or Underlined

Border Colour - select the preferred colour for the border, as by default, the 
border will use the colour of the layer on which the schedule is inserted

Background Colours – select the preferred colour for the background, as by 
default, the background will be blank

Justification - functionality not currently supported

Alignment - functionality not currently supported

Precision – Sets the precision of numerical text

Cell Fixed Width – cells can be variable or fixed width

Schedule Group Properties – schedules can be sorted by column and by data.

Standard 
Schedule Styles

To help with the creation of schedule styles, KeyTREE includes several predefined styles. 
These can be imported in to the drawing from the styles folder and can be modified or 
used as a template for the creation new styles.

Assigning 
Specification 

Styles

When inserting a schedule in the drawing the information will display according to the 
current style. However, you can have any number of styles available in a drawing and 
assign different styles to different schedules, as required. You can assign a style to a 
schedule, as follows:

• From the Tree drop-down, select Schedule Display>Modify/Set Style. You 
are returned to the drawing and prompted at the command line to Select 
Schedule to modify:

• Select the schedule(s) you wish to assign a different style and press Return. 
The Modify Schedule dialog will appear.
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• Select the schedule style you wish to use from the dropdown list or pick 
to create new and/or modify an existing Style·

• Pick [OK] to assign the style to the selected schedule(s).

Exporting Project 
Schedules

Project Schedule allows you to select a number of open or selected drawings to export as 
a combined file (project schedule) in a .CSV (comma separated value *.csv) text file. This 
file can be opened in a range of software, including MS Excel, MS Word, or MS Access.

• From the Tree drop-down, select Schedule>Project Schedule. The Project 
Schedule dialog appears.
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Style - allows you to select a schedule style currently referenced in the active 
drawing to define the information and format of the data to be exported. Pick 
to select an alternative style file.

Header - allows you to add text that will appear as a header to the exported 
schedule·

Currently Open Drawings - allows you to select any number of currently open 
drawing to include with the project export.

The drawings listed will include the current drawing and any other drawing 
opened in the background. It will always list the latest version of any drawing file  
so if an autosave has been performed on a drawing since it was last active, the 
drawing list will include the autosave version. These files will have a .SV$ file  
extension.

• Use [Select ->] to either select or clear all selection·

• Additional Drawings - allows you to add or remove additional drawings to 
include with the project export·
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• [Add] - allows to browse to an select additional drawing files to include within 
the project export·

• [Remove] - allows you to remove the currently selected drawing from the list 
of additional drawings.

• Export File - allows you to define the file name for the export file.

• Pick to define the folder where you wish the export file to be saved.

• Pick OK to complete the export of the entire selected drawing file(s). 

Project schedules are exported as a .CSV (comma separated value *.csv) text file. This 
text file can be opened in a range of software but usually requires you to set the Files of 
Type within the Open dialog to Text Files (*.txt, *.csv).
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Importing Survey 
Tree Data from 

External 
Databases

KeyTREE allows you to import site survey tree data directly into your AutoCAD drawing 
from a range of external file formats, including MS Access (.mdb), MS Excel (.xls), DBase 
File (.dbf) or Comma Separated Values (.csv). This allows you to capture site information 
from survey files and quickly populate your AutoCAD drawing. 

Preparing Your 
Drawing Before 
You Import Tree 

Data

Before importing your tree data it is recommended that you set the default settings for 
drawing the trees to prevent modifying each one individually once they are imported. 

• Open the read-only drawing KSTTree10.dwg from the KeyTREE Tutorials 
folder or use your own tree survey drawing. The drawing shows the locations for 
nine trees with their respective reference numbers.

• From the TREE pulldown menu, select Tree>Quick Add. The Add/Modify 
Tree dialog appears. 

 

• Pick [Display Options…]. The Tree Display Options dialog appears. 
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• Make the display settings required. For example, 
Stem Options tab – Set Blob Radius to 1m

Canopy Options tab – Set the Lineweight to 0.50mm (from the list)

• Make any additional changes required. Once defined, pick [Set Defaults]. This 
sets the default display options for the drawing, i.e. how the imported trees will display

• Pick [OK] to return to the Tree Display Options dialog. 

• Pick [Cancel]. This will allow you to set the default display options for the 
trees to be imported but will not insert a new tree into the drawing.

If you have set lineweights, to show them you will need to turn on the display Lineweights 
toggle on the status bar 

• Save the drawing for use in the next section 

Importing Tree 
Data – Easting 
and Northing’s 

NOT Defined 

In some cases you will receive a survey drawing from a surveyor that has the location of 
the trees with approximate tree canopy shapes. You may then annotate the trees and take 
the plot of the drawing to site to record the tree information. This tree data may be 
collected manually or electronically and then input or exported into a database, such as 
MS Access, or a spreadsheet, such as MS Excel. In this instance, the tree data will have 
reference numbers but no Easting and Northing locations defined although these locations 
are available in the surveyors AutoCAD drawing. You want to import the tree data and 
locate the trees using the survey drawing.

• Continue from the previous section or open the read-only drawing 
KSTTree11.dwg from the Tutorials, KeyTREE folder. This drawing shows the 
locations for nine trees with their respective reference numbers and has the 
display settings defined. 

• From the TREE pulldown menu, select Tree>Import. The Open KeyTREE 
Import Data dialog appears. 
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• Navigate to the KeyTREE Tutorials folder and to the Import Files sub-folder. 
Open the tree import file KST_Tree_Import.csv. The Import Tree Data dialog 
appears. 

The top half of the dialog lists the headings contained in the import file (Imported fields) 
and the Standard Fields defined in KeyTREE database. The bottom half of the dialog 
shows a preview of the data contained in the import file. 
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IMPORTANT: For an import file to be imported correctly, it is important that you preview the 
file first and “clean” the data, as necessary, i.e. you MUST ensure that the first row of the 
import file or table is the column headers with the site recorded data listed on rows 
beneath this. If this is not the case, it can be very difficult to assign the columns correctly 
and may result in some errors on import or inappropriate data being imported. Also, every 
tree record to be imported MUST have a tree reference number for the import routine 
to work.

• At the top of the dialog, you assign the data contained in the Imported Fields to 
the Standard Fields defined in KeyTREE database. 

• Under Imported Field, pick the first record, e.g. Tree Ref. No., under 
Standard Fields, double-click the Select… cell or pick on the down arrow. A 
list of data fields defined on the KeyTREE database appear.

• Select the relevant data field on the database that matches your import data, 
e.g. Tree Ref. No. matches to Survey – Reference.

• Repeat for each record you wish to import. 

• When the import field includes a measurement, you will be required to define 
the measurement type (m, cm, or mm) as it is quite frequent that the survey 
data has some data defined in one unit (e.g. tree canopy and height details in 
metres) but other data to be defined in another unit (e.g. stem diameter in 
millimetres). 
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If this is a standard form of import that you will use again, once all the required import fields 
have been assigned to the KeyTREE standard fields, you can save this as a template file. 
Use the Export function to save the file to your required location and Import to use the 
template file again. All import template files are saved with a .ktip file extension.

When all the necessary Import Fields are assigned to the KeyTREE database 
Standard Fields, under Select Rows to Import, pick the records you wish to 
import using standard Windows selection keyboard key options, e.g. 

Ctrl+A (or drag down the list) - selects all records

Ctrl+pick - selects only the selected record(s)

Shift+Pick - selects all records between first and second pick. 

The above selection methods allow you to be selective in the records you import, if this is 
required, e.g. where you have amended the tree data and only wish to re-import the 
updated information.

• In this example select all the rows to import. 

• Once selected, pick [OK].

• At the command line you will be prompted:

Select Insertion Point for Tree Ref: 143

• In the AutoCAD drawing pick the centre point of the circle (using object snaps) 
that represents tree 143. 

• You are then prompted for the next tree (144). 

• Repeat for each tree. 

You can stop the import at any time by pressing [Esc]. If you cancel the import it will  
cancel all trees already located in the drawing so you are prompted. 

Pick [Yes] to cancel the import so that tree locations already defined are lost or [No] to 
continue to add the selected trees to import.

• If the import file contains tree species that are not defined on the KeyTREE 
database, the Select Species Group dialog appears. 
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• For each tree species you must assign the species to either the Trees or 
Conifers Species Group. 

IMPORTANT: If you pick Cancel at this stage it will cancel the entire import.

• When all the trees selected for import are inserted in the drawing, the Tree 
Import dialog will appear and notify of the number of records that have been 
successfully imported.

• Pick [OK].

The imported tree data will now appear as new trees in the drawing and will display based 
on the default display options set before the trees were imported. 
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Importing Tree 
Data – Easting 
and Northing’s 

Defined 

In some cases you may collate a tree survey that includes the tree data and the tree 
locations, defined as either Easting’s and Northing’s or X and Y co-ordinates.

Open the read-only drawing KSTTree13.dwg from the Tutorials, KeyTREE folder. 
This is an extract from site drawing that already has the tree display options defaults 
defined. 

• From the TREE pulldown menu, select Tree>Import. The Open KeyTREE 
Import Data dialog appears.

• Navigate to the KeyTREE Tutorials folder and to the Import Files sub-folder. 
Open the tree import file KST_Tree_Import (Easting&Northing).csv. 

• The Import Tree Data dialog appears.

• Assign all the Imported Field fields to the relevant database fields under 
Standard Fields.
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To assist you, a predefined template for the import is available. Pick [Import], navigate to 
the KeyTREE Tutorials folder and Files sub-folder. Open the file KST_Tree_Import_(N& 
E).ktip file. This will complete top half of the dialog and assign the Imported Field fields to 
the relevant database fields under Standard Fields.

• Once assigned, under Select Rows to Import, pick the records you wish to 
import. In this case all tree records can be selected.

• Pick [OK]. 

• After a short while you will be notified that the trees have been successfully 
imported in to the drawing.

• Pick [OK]. You are returned to the drawing and, as the Easting and Northing 
(X and Y) values are defined, the trees automatically appear in the drawing. 

Importing Tree 
Data – BS 

Categories 
Defined 

In some cases you will include the BS categories in the tree survey file to be imported. 
KeyTREE will automatically assign the trees to their respective layers and colour them 
according to the BS on import. 

Using display options (see “Preparing Your Drawing Before You Import Tree Data” earlier 
in this section), define which elements of the tree are to be coloured in accordance with the 
BS colours, e.g. stem, canopy, RPA, etc.
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• Open the read-only drawing KSTTree13.dwg from the Tutorials, KeyTREE 
folder. This drawing shows the locations for nine trees with their respective 
reference numbers and has the display settings defined.

• From the TREE pulldown menu, select Tree>Import. The Open KeyTREE 
Import Data dialog appears.

• Navigate to the KeyTREE Tutorials folder and to the Import Files sub-folder. 
Open the tree import file KST_Tree_Import (Categories).csv. 

• The Import Tree Data dialog appears.

• Assign all the Imported Field fields to the relevant database fields under 
Standard Fields.

To assist you, a predefined template for the import is available. Pick [Import], navigate to 
the KeyTREE Tutorials folder and Files sub-folder. Open the file 
KST_Tree_Import_(Categories).ktip file. This will complete top half of the dialog and 
assign the Imported Field fields to the relevant database fields under Standard Fields.

• Once assigned, under Select Rows to Import, pick the records you wish to 
import. In this case all tree records can be selected

• Once selected, pick [OK].

• At the command line you will be prompted:

Select Insertion Point for Tree Ref: 143

• In the AutoCAD drawing pick the centre point of the circle (using object snaps) 
that represents tree 143. 

• You are then prompted for the next tree (144). 

• Repeat for each tree. 

• When all the trees selected for import are inserted in the drawing, the Tree 
Import dialog will appear and notify of the number of records that have been 
successfully imported.

• Pick [OK].

The imported tree data will now appear as new trees in the drawing and will display based 
on the BS category colours and default display options set before the trees were imported. 

KeyTREE Tutorial 2-37
KeyTREE Section 2 Revision 1



Key Systems Advanced KeyTREE Features

Sun, Shadows and 
Location

KeyTREE calculates an approximation of shadows cast by a tree based on the canopy 
spread, its overall height and the stem clearance height. If any of this data is not defined, 
shadows may not show as expect or may not show at all if the tree height is not specified. 
 
• Continue from the previous section or open a drawing that contains trees 

inserted using KeyTREE
• From the Tree menu, select Sun, Shadows and Location. The Sun, 

Shadows and Location toolbar appears along with the Sun Properties tool 
palette. 
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To Set your Site 
Location

• Within the Sun Properties tool palette, next to Geographic Location, pick the 
launch Geographic Location icon. 
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• The Geographic Location – Define Geographic Location dialog box 
appears. 

• If you have a .klm or .kmz file exported from Google Earth or you have your 
current site location defined in Google Earth, pick the option that applies. If 
you wish to approximate the current location of your site to assess the 
shadows pick Enter the location values. The Geographic Location dialog 
appears. 
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• If you know the Latitude and Longitude of the site or the XY(Z) location of the 
site, please enter these as appropriate. If you wish to approximate the current 
location of your site to assess the shadows pick [Use Map…].The Location 
Picker Dialog appears. 
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• You can pick the nearest location on the map at the top of the dialog and/or 
select this from the Nearest City the drop down. Please note that there are a 
limited number of UK options. 

• Once set, pick [OK]. The Geographic Location – Time Zone Updated dialog 
appears. 

• Pick Accept undated time zone to accept the time zone. You are returned to 
the Geographic Location dialog. Pick [OK] to accept the location. 
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To Show and 
Update Shadows 

in the Drawing 

• To show the shadows, pick the Update Shadows icon from Sun, Shadows 
and Location toolbar.

• The shadows will now appear in the drawing. 

• Change the time of day or date as required, using the Sun Angle Calculator 
section of the Sun Properties tool palette. After any change you MUST update 
the shadows, by picking the Update Shadows icon on the Sun, Shadows 
and Location toolbar. 

To Turn Off or 
Change the 

Shadow Colour 

• The shadows will be created on their own layer, typically 7_TREES_ 
SHADOW. As you change a tree BS category it will move the tree to the 
appropriately named layer along with the shadow so an A1 category tree will  
put its shadow on the layer 7_TREES_A1_SHADOW.

• Using the AutoCAD Layer Manager, you can turn off or change the colour of 
the shadow layer(s) as required. To update the layer changes, go to View and 
pick Regen to regenerate the view and apply the changes. 

Shadow Analysis 
Per Layout / 

Viewport 

Each Layout viewport can support its own sun system that can be different to the one 
defined in the Model. This allows you to consider different times of the day or days of the 
year on an individual viewport by viewport basis.

• To set the sun system for a viewport, activate the Layout and viewport (e.g. 
double-click inside the viewport frame) in which you wish to define a different 
shadow analysis.

• As outlined above, turn on the Sun (Status) and set the time of day and date 
for the viewport. You will only need to set the geographic location if this has 
not already been defined. 

• Make the necessary time of day or date changes, as appropriate. To show the 
change you MUST update the shadows, by picking the Update Shadows icon 
on the Sun, Shadows and Location toolbar. Repeat this process to consider 
different times or dates for the viewport.

Each viewport supports its own sun system so the above process can be repeated for 
each viewport as appropriate, see example below,

KeyTREE Tutorial 2-43
KeyTREE Section 2 Revision 1



Key Systems Advanced KeyTREE Features

Distributing 
KeyTREE 
Drawings

KeyTREE uses the latest AutoCAD-based, object-orientated design. Like Autodesk’s own 
applications for Architecture, Mechanical and Civil design, KeyTREE creates intelligent 
AutoCAD objects that are visible, but not be editable, in general AutoCAD. AutoCAD will 
usually show these objects using simplified proxy (image) graphics that will not be editable 
in AutoCAD unless you install the KeyTREE object enablers for your version of AutoCAD. 
Depending on your AutoCAD settings, the proxy entities may display as bounding boxes or 
may not show them at all. See sections below for more information. 

Sending KeyTREE 
Drawings to 

AutoCAD Users

Please follow the following procedures to ensure you save a drawing correctly BEFORE 
sending it to AutoCAD:

• Open the drawing to be sent to the AutoCAD user

• At the command line enter PROXYGRAPHICS and press Return. The default 
value of the AutoCAD system variable should be 1. If it is set to 0, enter 1 and 
press Return.

The  AutoCAD  PROXYGRAPHICS  system  variable  specifies  whether  images  of  proxy 
objects are saved in the drawing or not. If set to 1 the drawing saves the proxy graphic  
images so that they are available to display in AutoCAD. If set to 0, the proxy graphics 
images are NOTsaved with  the drawing and so,  when opened in  AutoCAD, KeyTREE 
objects may not display or appear as bounding boxes.

• At the command line enter ISAVEPERCENT and press Return. The default 
value of the AutoCAD system variable should be 50, although not necessarily.

The AutoCAD ISAVEPERCENT (Incremental Save Percentage) system variable is a global  
setting (i.e. affects all drawings) that sets the percentage of potentially wasted space in a 
drawing file. If the Incremental Save Percentage is set to 0, every save is a full save. Full  
saves eliminate wasted space and can reduce drawing size but the performance of the  
SAVE and SAVEAS commands will slow significantly. Incremental saves are faster but they 
increase the size of your drawing as it includes wasted space. For optimum performance 
AutoCAD sets the default  value to 50. That is, if less than half the drawing is modified 
between  saves  the  change  only  information  is  appended  to  the  drawing  database. 
Conversely, if more than half the drawing is altered between saves, a full save is invoked. 

• At  the  prompt:  Enter  new  value  for  ISAVEPERCENT,  enter  0  and  press 
Return

• Save the drawing. This will invoke a full save of the drawing.

• At the command line enter ISAVEPERCENT and press Return. 

• Enter 50 (or your previous value setting) and press Return

• Close the drawing 

• Send your drawing to your client or design partner 

Opening KeyTREE 
Drawings in 

AutoCAD

Please advise your clients or design partner of the following procedures BEFORE they 
attempt to open a KeySCAPE drawing in AutoCAD

• When the AutoCAD user open the drawing in AutoCAD the Proxy Information 
dialog should appear 
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• Select the option Show proxy graphics and pick [OK] to open the drawing 
and display the KeySCAPE objects

What  to  do  if  the  Proxy  Information dialog  does not  appear AND the  KeyTREE 
graphics do not show

In this instance it is likely that the AutoCAD settings that control these options have been 
set to not display the Proxy Information dialog or, more importantly, to not show the proxy  
graphics. In this instance:

• With the drawing closed, at the command line enter PROXYSHOW and press 
Return. The current value of the AutoCAD system variable is displayed and is 
most likely to be set to 0, i.e. to not show proxy objects

• At the prompt:  Enter new value for PROXYSHOW, enter  1  (to show proxy 
objects) and press Return

The AutoCAD PROXYSHOW system variable is a global setting (i.e. affects all  
drawings) that controls the display of proxy objects in an AutoCAD drawing where 
the application that  created the objects is  not  available.  The following options 
exist:

0 Proxy objects are not displayed

1 Graphic images are displayed for all proxy objects

2 Only the bounding box is displayed for all proxy objects

• Open the KeyTREE drawing in AutoCAD and all the graphics will show as 
image entities only, i.e. not editable as AutoCAD objects 

Object Enablers If a drawing is opened with proxy graphics showing you will only have access to limited 
editing features on the object, e.g. delete. However, should you wish to undertake more 
detailed editing, you can request and install the KeyTREE Object Enablers for your version 
of AutoCAD. Once installed, this will give limited access to the objects and allow you to use 
most of the AutoCAD editing commands on KeyTREE objects, e.g. copy, move, rotate, 
grips etc. However, it does not allow any access to the KeyTREE user interface to edit  
settings, specifications or planting/hedge graphics. This information can only be edited in 
KeyTREE. Any changes made in a KeyTREE (object) enabled AutoCAD will be updated 
next time the drawing is opened in KeyTREE. 
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SaveAs to earlier 
version of 
AutoCAD 

Due to limitations imposed by Autodesk on objects, any KeyTREE drawing that is created 
or opened and saved in a newer version of AutoCAD, will not be editable in versions of 
KeyTREE running on earlier versions of AutoCAD, even though the KeyTREE functionality 
may be identical, i.e. there is NO backward compatibility between AutoCAD/KeyTREE 
objects This also applies to the use of KeyTREE enabled versions of AutoCAD. There is 
no work round to this!

SaveAs to earlier 
version of 
AutoCAD 

Due to limitations imposed by Autodesk on objects, any KeyTREE drawing that is created 
or opened and saved in a newer version of AutoCAD, will not be editable in versions of 
KeyTREE running on earlier versions of AutoCAD, even though the KeyTREE functionality 
may be identical, i.e. there is NO backward compatibility between AutoCAD/KeyTREE 
objects This also applies to the use of KeyTREE enabled versions of AutoCAD. There is 
no work round to this!

Exploding 
KeyTREE Objects

Limitations, imposed by Autodesk on custom objects prevent the use of DXFOUT and 
DXFIN unless the objects are exploded to simple drawing entities. These simplified 
versions of the objects have no intelligence but allow them to be edited in AutoCAD or 
other applications, such as SketchUp, Adobe Illustrator or CorelDRAW 

You  can  explode  KeyTREE  objects  using  the  AutoCAD  Explode  Command.  
However,  you  will  need  to  explode  the  objects  twice to  get  back  to  single  
AutoCAD entities. Please note that the following default results:

First use of the AutoCAD Explode Command on KeyTREE objects – 
explodes each object into individual AutoCAD blocks, i.e. one new block is 
created for each object.

Second use of the AutoCAD Explode Command on KeyTREE objects – 
explodes each individual AutoCAD block, derived from the objects, in to single 
editable AutoCAD entities. 

IMPORTANT: Exploding the KeyTREE objects WILL destroy all object functionality and 
associated intelligence, e.g. automatic update of plant number calculations and schedules. 
Once the drawing has been closed, the links can NOT be recreated automatically.  
Therefore, it is strongly recommended that you make a backup of the drawing (SaveAs) 
BEFORE exploding the objects. After exploding the drawing, your drawing size may 
increase considerably. 
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