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 KeySCAPE - Advanced Features 
 

Creating your 
own 

Vegetation 
Symbol  

 

KeySCAPE provides you with the facility to quickly create and add new symbols to 
the system, allowing you to develop your own graphic style for your drawings. You 
can add graphics to the specific symbol types, e.g. trees, benches, arrows, etc, to 
expand the default palettes. Also, KeySCAPE includes three blank Project Symbol 
libraries where you can add, and quickly retrieve, your own preferred graphics. 
 
Drawing the Symbol 
 
• From the File menu select New to start a new (Blank) drawing based 

on the ACADISO.dwt (AutoCAD metric) template or KSLTOSO.dwt 
(KeySCAPE LT metric) template. 

• From the Draw pulldown menu, select Circle>Centre, Radius 
• When requested at the command prompt to Specify center point for 

circle, enter 0,0. 
 
This will put the centre of the circle at the co-ordinate 0,0, the insertion reference 
point used when it is inserted in a KeySCAPE drawing later. 
  
• When requested at the command prompt to Specify radius of circle 

or [Diameter], enter (a radius of) 0.5. 
 
This will create a 1 unit diameter circle. This means that when it is inserted in to a 
drawing, you can define the spread of the vegetation drawing and the symbol will 
scale correctly. 
 
• From View>Zoom menu select Extents. The circle will now fill the 

drawing editor.  
 
If the circle looks angular, from View menu select Regen to refresh the display 
and smooth the circle. 
 
• From Format>Layer, create a new layer called T_plan_01 and assign 

the colour 64, or other required, to the new layer.  
• Make the layer T_plan_01 Current. Pick [OK]. 
• Create, using AutoCAD’s drawing tools, your own unique vegetation 

drawing using the construction circle as a guide, e.g. 
 

                      
 
• Once the symbol id defined, erase the construction circle used to 

define the drawing extents. 
• From View>Zoom select Extents. The symbol will now fill the drawing 

editor. 
• When you have created your symbol, select File>Save and navigate 

to the directory: 
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       C:\KeySCAPE Systems Application Data\ 
              All Users\ 
                  KeyCORE\ 
                       Symbols\ 
                            Project 1\ 
                                Plan\ 
                                    Vegetation 
 
• For the drawing name, enter Mytree, or other name as required, and 

select Save. Close the drawing 
• The vegetation symbol will be added to the Project 1 Symbol Library. 
 
Alternatively, you can save the drawing in the corresponding folder under Trees 
(typically Symbols\Trees\Plan\Vegetation) and it will then appear in the Trees 
symbol selector dialog within KeySCAPE next time you insert a tree symbol. 
 
 
Using your New Symbol 
 
 
• Open the drawing into which you wish to insert the new symbol. 
• From Core, select Project Libraries>Project 1. The Project 1 dialog 

appears. 
• Select the Plan tab to display your plan symbol. 
• Double-click the image icon. You are returned to the drawing editor. 
• At the command line you are prompted: 
 
                 Insertion Point:                    (Pick the insertion point of the tree) 
                 Spread:                               (Enter the spread of the tree) 
                 Height:                                (Enter the height of the tree) 
                 Rotation:                             (Enter the rotation for the tree) 
 
• The vegetation symbol you created will now appear in the drawing. 
 
The symbol created will remain in the project library unless you choose to delete it 
using Windows Explorer.  
 
KeySCAPE contains 3 project libraries. These allow you to create and add your 
own graphics to the system to build up your own palette of symbols for quick 
access to your preferred symbols. These can be accessed, as described above, 
or by using the shortcut keys: 
                                      P1-  Project 1 
                                      P2-  Project 2 
                                      P3-  Project 3 
 
 

Creating your 
own 

Vegetation 
Edge Pattern  

 

KeySCAPE now provides you with the facility to quickly create and add new line 
patterns for use with hedges and planting areas, allowing you to develop your own 
graphic style for your drawings. 
 
Drawing the Pattern 
 
• From the File menu select New to start a new (Blank) drawing based 

on the ACADISO.dwt (AutoCAD metric) template or KSLTOSO.dwt 
(KeySCAPE LT metric) template. 

• From the Draw pulldown menu, select Line. 
• When requested at the command prompt to Specify first point: pick a 

point on the screen where you wish to start drawing the line. This point 
does not need to be 0,0. 

• When requested at the command prompt to Specify next point or 
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[Undo]: enter @1,0. and press Return. This will draw a construction 
line 1 unit in the X and 0 in the Y. 

• Press Return to complete the line command. 
• From View>Zoom, select Extents. The line will now fill the drawing 

editor. 
• This (construction) line will provide a template that ensures that the 

pattern scale and start point is set correctly. 
• Create a new layer, e.g. KST_PATTERN_01 and make the new layer 

Current.  
• Pick [OK]. 
 
IMPORTANT – Patterns MUST be drawn in metres, fit within 1 drawing 
unit, and must comprise of only polylines or arc-segmented polylines 
but NOT arcs, lines or circles.  
 
• From the Draw toolbar, select Polyline. 
• Using the construction line as a guide, draw the required pattern so 

that polyline fits between the start and endpoints of the line. 

 
 
The pattern can be created from several polylines. These polylines do not need to 
start and end on the endpoints of the construction line but this will create gaps in 
the graphics when used later in the drawing. 
 
• When the pattern is complete, you can convert it into a new pattern.  
 
Converting the Drawing into a Pattern 
 
• From the Softworks pulldown menu, select Pattern Manager. The 

Pattern Manager dialog will appear. 
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• Pick [New].  You are retuned to the drawing. 
• At the command line prompt to Select Objects: pick the polylines that 

defines the pattern, excluding the contraction line, although this should 
be filtered out, as it is a line not a polyline. 

• At the command line prompt to Select Pattern Origin:, using the 
OSNAP Endpoint, pick the end of the line at the start of the pattern 
(furthest left). The Pattern Name dialog appears.  

 
You do not need to define the other end of the pattern as KeySCAPE assumes 
the length of the pattern is I unit, hence the purpose of the original construction 
line. 
 

      
 
• Enter a new name for the pattern, e.g. KST Pattern. 
• Pick [OK]. The Pattern Manager dialog will reappear and the pattern 

will be displayed in the list. 
• Pick [Finished] to complete the creation of the pattern. 
 
Saving the Pattern to Create a Preview Thumbnail  
 
• Delete the construction line used to define the extents of the pattern 

but NOT the polylines that define the pattern. 
• From View>Zoom, select Extents so the pattern fills the screen. 
• From File select Save. The Save dialog appears. 
• From the Save in dropdown list (top of dialog), navigate to the 

softworks edge pattern folders, typically: 
 
              C:\KeySCAPE Systems Application Data\ 
                    All Users\ 
                      KeySOFTWORKS\ 
                        Symbols\Patterns\ 
                          Softworks Edges\ 
                            Select Only 
 
• Enter the name for the drawing name which MUST be the same name 

as the pattern defined above, e.g. KST Pattern. 
• This will create a drawing (preview thumbnail) in the Patterns selection 

dialog. 
 
Using your New Pattern  
 
• Use the patterns you define when adding or modifying either a Planting 

Area or Hedge. See Section 2 for information on creating and 
modifying Hedges and Planting Areas. 

 
 
 
 
 
 

Specification Styles allow you to define or redefine the display of specification information in the 
drawing. 
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Styles  
Styles are a common means of displaying and modifying the appearance of an 
AutoCAD object in the drawing. You will be familiar with some of these using 
general AutoCAD, e.g. Text Styles, Dimension Styles, Plot Styles. 
 
Autodesk has extended this functionality to control the display of objects in their 
own applications, such as Architectural Desktop, Map 3D, Civil Design. Styles 
allow you to quickly modify aspects of the object (or its display) and see the 
immediate affect of the change, not only to the main object but also to all "linked" 
objects, thus speeding up modifications to the drawing and the consideration of 
design options. 
 
KeySCAPE uses Styles to control how information in a specification label or 
schedule is displayed. Drawing Setup (Core) allows you to create and define the 
default styles before you start drawing but you have the flexibility to create more 
styles and modify existing ones as you start designing. 
 
 
Modify the Appearance of Plant Specification Text 
 
Also refer to Section 2: “Modifying a Specification – Specimen” for information 
regarding changing the Specification text font, height, angle (rotation) and 
redefining the specification leader.  
 
• From the Softworks pulldown, select Specification Display>Styles. 

The Specification Style dialog appears. 
 

        
 
You can also access the specification styles from Core>Drawing 
Setup>Softworks Styles (tab)>Specification Style>  
 
You can modify the current style as follows: 
 
• Style Name – drop down list showing the Specification Styles 

available in the current drawing. The default style, KeySOFTWORKS 
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Elements Standard will be created with every new drawing opened 
with KeySCAPE 

• [Rename...] - allows you to rename the currently selected Style 
• [Copy Existing...] - allows you to make a copy of the currently 

selected Style and edit the display specification information so the 
original style remains unedited. 

• [Delete...] - allows you to delete the currently selected Style from the 
drawing. You will not be able to delete a style if it is being used in the 
drawing 

• [Import...] & [Export...] - Specification Styles can be exported and 
imported as *.kis files. This provides the facility to export styles 
defined in one KeySCAPE drawing to import in another KeySCAPE 
drawing. If these files are held on a network, or shared drive, they can 
be used by several users, as required.  

 
The default KeySOFTWORKS Element Standard style will be created with every 
drawing opened with KeySCAPE. If you wish to define your own default template, 
modify and export your preferred style overwriting the KeySOFTWORKS 
Elements Standard.kis file. It is recommended that you make a copy of the original 
file before overwriting it in case you need to restore the default installed style in the 
future. 
 
• Text - [Settings...] - allows you to specify the text settings for the 

currently selected Style, including: 
 

              
 

Style - pick from the list of current (AutoCAD) Text Styles defined 
in the drawing 
Height - specify the height of the text relative to the current 
drawing units (M, MM or Inches) 
Colour - select the preferred colour for the text as, by default, the 
text will take on the colour of the layer on which the object is 
inserted 
Border -  functionality not currently supported 
Justification - defines whether the specification text is justified 
left, right or centred about the picked insertion point 
Alignment - functionality not currently supported 

• Text - Indent Size [  ] - sets the size, based on your drawing units, of 
the indents used to display Object and Specification Data. 

• Leader - allows you to specify the appearance of the leader, 
including: 

Pointer Style - uses a system default of Blob only. Modification of 
this is not currently supported 
Colour - allows you to define the colour of the leader as, by 
default, the leader will take on the colour of the layer on which the 
object is inserted. 
Show Header At Leader Points – allows you to replace leader 
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points with header text defined within the specification of the 
plant. 

• Object Data (tab) - allows you to specify the data and display of 
general information (e.g. area, length, etc.) you wish to show in the 
current Style 

• [Insert] - allows you to add specification data, chosen from the 
associated drop-down list, to a selected cell. This cell must be "active" 
(selected) and blank for the specification item to be inserted. 

 

•  Remove Data - select the specification item you wish to remove 
and pick the delete button from the navigation bar 

 
• Navigation Buttons - use the appropriate buttons to define/redefine 

the position of a selected specification item within the grid, and thus 
its eventual display location in the drawing 

 

                          
 
In addition to the navigation buttons, you can move single items within the grid 
using pick and then drag and drop, 
 
Whilst a grid is used to set up the general position of specification information, 
KeySCAPE uses the settings defined in Text Size (Settings) and Indent Size to 
control the vertical and horizontal spacing of this information when displayed in the 
drawing. As such, use text size to control the vertical display and number of blank 
cells, in conjunction with Indent Size (in drawing units), to set the amount the text 
steps either in or out 
 
• Pick [Yes] to accept the changes or [No] to cancel the command. If 

you pick yes, the appearance of the tags will change after a short 
time. 

 
Standard Specification Styles 
 
To help with the creation of specification styles, KeySCAPE includes several 
predefined styles. These can be imported in to the drawing from the styles folder 
and can be modified or used as a template for the creation new styles. 
 
Assigning Specification Styles 
 
When inserting a specification in the drawing the information will display according 
to the current style. However, you can have any number of styles available in a 
drawing and assign different styles to selected specifications, as required. You can 
assign a style to a specification, as follows: 
 
• From the Softworks pulldown, select Specification Display>Set 

Style. You are returned to the drawing and prompted, at the command 
line, to Select objects: 

• Select the specifications you wish to assign a different style.  
• When all required specifications are selected, press Return. The Set 

Style dialog will appear. 
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• From the dropdown list, pick the specifications style you wish to apply 

to the selected specifications.  
• Pick [OK] to assign the style.  
 
 

Distributing 
KeySCAPE 

Drawings 
 

KeySCAPE uses the latest AutoCAD-based, object-orientated design. Like 
Autodesk’s own applications for Architecture, Mechanical and Civil design, 
KeySCAPE creates intelligent AutoCAD objects that are visible, but not be 
editable, in general AutoCAD. AutoCAD will usually show these objects using 
simplified proxy (image) graphics that will not be editable in AutoCAD unless you 
install the KeySCAPE object enablers for your version of AutoCAD. Depending on 
your AutoCAD settings, the proxy entities may display as bounding boxes or may 
not show them at all. See sections below for more information. 
 
Sending KeySCAPE Drawings to AutoCAD Users 
 
Please follow the following procedures to ensure you save a drawing correctly 
BEFORE sending it to AutoCAD: 
 
• Open the drawing to be sent to the AutoCAD user 
• At the command line enter PROXYGRAPHICS and press Return. The 

default value of the AutoCAD system variable should be 1. If it is set 
to 0, enter 1 and press Return. 

 
The AutoCAD PROXYGRAPHICS system variable specifies whether images of 
proxy objects are saved in the drawing or not. If set to 1 the drawing saves the 
proxy graphic images so that they are available to display in AutoCAD. If set to 0, 
the proxy graphics images are NOTsaved with the drawing and so, when opened 
in AutoCAD, KeySCAPE objects  may not display or appear as bounding boxes. 
 
• At the command line enter ISAVEPERCENT and press Return. The 

default value of the AutoCAD system variable should be 50, although 
not necessarily. 

 
The AutoCAD ISAVEPERCENT (Incremental Save Percentage) system variable is 
a global setting (i.e. affects all drawings) that sets the percentage of potentially 
wasted space in a drawing file. If the Incremental Save Percentage is set to 0, 
every save is a full save. Full saves eliminate wasted space and can reduce 
drawing size but the performance of the SAVE and SAVEAS commands will slow 
significantly. Incremental saves are faster but they increase the size of your 
drawing as it includes wasted space. For optimum performance AutoCAD sets the 
default value to 50. That is, if less than half the drawing is modified between saves 
the change only information is appended to the drawing database. Conversely, if 
more than half the drawing is altered between saves, a full save is invoked.  
 
• At the prompt: Enter new value for ISAVEPERCENT, enter 0 and 

press Return 
• Save the drawing. This will invoke a full save of the drawing. 
• At the command line enter ISAVEPERCENT and press Return.  
• Enter 50 (or your previous value setting) and press Return 
• Close the drawing  
• Send your drawing to your client or design partner 
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Opening KeySCAPE Drawings in AutoCAD 
 
Please advise your clients or design partner of the following procedures BEFORE 
they attempt to open a KeySCAPE drawing in AutoCAD 
 
• When the AutoCAD user open the drawing in AutoCAD the Proxy 

Information dialog should appear 
 

       
 
• Select the option Show proxy graphics and pick [OK] to open the 

drawing and display the KeySCAPE objects 
 
What to do if the Proxy Information dialog does not appear AND the 
KeySCAPE graphics do not show 
 
In this instance it is likely that the AutoCAD settings that control these options 
have been set to not display the Proxy Information dialog or, more importantly, to 
not show the proxy graphics. In this instance: 
 
• With the drawing closed, at the command line enter PROXYSHOW 

and press Return. The current value of the AutoCAD system variable 
is displayed and is most likely to be set to 0, i.e. to not show proxy 
objects 

• At the prompt: Enter new value for PROXYSHOW, enter 1 (to show 
proxy objects) and press Return 

 
The AutoCAD PROXYSHOW system variable is a global setting (i.e. affects all 
drawings) that controls the display of proxy objects in an AutoCAD drawing where 
the application that created the objects is not available. The following options exist: 

0      Proxy objects are not displayed 
1      Graphic images are displayed for all proxy objects 
2      Only the bounding box is displayed for all proxy objects 

 
• Open the KeySCAPE drawing in AutoCAD and all the graphics will 

show as image entities only, i.e. not editable as AutoCAD objects 
 
 
Object Enablers 
If a drawing is opened with proxy graphics showing you will only have access to 
limited editing features on the object, e.g. delete. However, should you wish to 
undertake more detailed editing, you can request and install the KeySCAPE 
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Object Enablers for your version of AutoCAD. Once installed, this will give limited 
access to the objects and allow you to use most of the AutoCAD editing 
commands on KeySCAPE objects, e.g. copy, move, rotate, grips etc. However, it 
does not allow any access to the KeySCAPE user interface to edit settings, 
specifications or planting/hedge graphics. This information can only be edited in 
KeySCAPE. Any changes made in a KeySCAPE (object) enabled AutoCAD will be 
updated next time the drawing is opened in KeySCAPE. 
 
SaveAs to earlier version of AutoCAD 
Due to limitations imposed by Autodesk on objects, any KeySCAPE drawing that 
is created or opened and saved in a newer version of AutoCAD, will not be 
editable in versions of KeySCAPE running on earlier versions of AutoCAD, even 
though the KeySCAPE functionality may be identical, i.e. there is NO backward 
compatibility between AutoCAD/KeySCAPE objects  This also applies to the use of 
KeySCAPE enabled versions of AutoCAD. There is no work round to this! 
 
 
 

Exploding 
KeySCAPE 

Objects 
 
 
 

Limitations, imposed by Autodesk on custom objects prevent the use of DXFOUT 
and DXFIN unless the objects are exploded to simple drawing entities. These 
simplified versions of the objects have no intelligence but allow them to be edited 
in AutoCAD or other applications, such as SketchUp, Adobe Illustrator or 
CorelDRAW  
 
You can explode KeySCAPE objects using the AutoCAD Explode Command. 
However, you will need to explode the objects twice to get back to single 
AutoCAD entities. Please note that the following default results: 
 
First use of the AutoCAD Explode Command on KeySCAPE objects – 
explodes each object into individual AutoCAD blocks, i.e. one new block is created 
for each object. 
 
Second use of the AutoCAD Explode Command on KeySCAPE objects – 
explodes each individual AutoCAD block, derived from the objects, in to single 
editable AutoCAD entities.  
 

IMPORTANT: Exploding the KeySCAPE objects WILL destroy all object 
functionality and associated intelligence, e.g. automatic update of plant number 
calculations and schedules. Once the drawing has been closed, the links can NOT 
be recreated automatically. Therefore, it is strongly recommended that you make 
a backup of the drawing (SaveAs) BEFORE exploding the objects. After exploding 
the drawing, your drawing size may increase considerably.. 

 
 


