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 KeySCAPE - Advanced Features 
 

Updating a 

Legacy 
KeySCAPE or 

KeyPLANTING 
Drawing 

 

KeySCAPE has introduced many new features that are not supported in earlier 
versions of KeySCAPE or KeyPLANTING. When you open a drawing created in an 
earlier release of KeySCAPE/KeyPLANTING, you will be notified of this fact and 
advised to update the drawing. It is recommended that you do a SaveAs either 
before or after the migration as, once saved in the latest version, you WILL NOT be 
able to open the drawing again in earlier versions. 

 

Migrating the Drawing On Open 
 

  When you open a drawing from an earlier release of 
KeySCAPE/KeyPLANTING, a notification dialog will appear with the 
option to update (migrate) your drawing. 

 

      
 
  Picking [Yes] will migrate the drawing so you can continue to work on 

the drawing and make use of the new features. (See the section below 

“Migrating the Drawing After Opening” for information regarding migrating 
drawings) 

 

IMPORTANT:  

  Migrating the drawing MAY affect the display of some features and delete 
certain information, including partial schedules and inappropriately labelled 
planting tags. Full schedules will remain in the drawing but the information 
contained within the schedule is likely to change 

  You are advised to check the drawing after migration to identify where, if 
any, discrepancies have occurred. 

  It is STRONGLY recommended that you perform a SaveAs to protect the 
integrity of the original drawing.  

 

  Picking [No] will leave the drawing in its current state and may be useful 
if you only wish to open the drawing to view or plot. 

 
If you select No, it is STRONGLY recommended that you do not save the 

converted drawing in this state to protect the integrity of the original drawing. 
 

Migrating the Drawing After Opening 
In some instances you may need to Recover (see AutoCAD Help on Recovering 
drawings) the drawing before migrating it or you may not wish to migrate the 
drawing on opening so that you can view it first then wish to migrate it later. In this 
instance, cancel the option to migrate the drawing upon opening. When you wish to 
update the drawing, proceed as follows: 

 

  From the Core menu select Update Drawing. You are notified: 
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  Pick [OK] to migrate the drawing. When complete you will be notified: 
 

      
 

  Pick [OK]  

  Now save the drawing, using File>SaveAs, to maintain the integrity of 
the original drawing. 

  You can now work on the drawing using the new features. 
 
IMPORTANT 
If you do not wish a legacy drawing to change its appearance, DO NOT save it in the 
latest version. However, when you choose to update a legacy drawing, KeySCAPE 

performs a series of actions that MAY affect the display of information in the former 
drawing. 
 

Once the drawing has been migrated you are STRONGLY advised to save the 
converted drawing to a new file name using the SaveAs command thus keeping the 
original legacy KeySCAPE drawing. If there are issues with the conversion process 
having a copy of the original may be the only way to successfully resolve these 
problems if you require assistance from Key Systems technical support. 
 
Once a drawing has been migrated you can no longer work on it in KeySCAPE FP. 
If you attempt to do so the drawing can become corrupt and may be un-recoverable. 
 

Migrating Legacy Drawings – Knowledge Base 
 

The following is a brief summary of the most noticeable changes that result from 
opening or migrating legacy drawings and how these can be resolved:  
 
Issue: 

Opening a drawing in the latest version prior to conversion, graphics, tags 

and schedules do not appear. 
Solution: 
For this information to show you must have saved the original drawing in the original 
version (not the current version) with the AutoCAD system variable 
PROXYGRAPHICS set to 1. This setting forces AutoCAD to save the proxy entity 
display (image) graphics with the drawing. AutoCAD uses this to display the objects 
in the drawing. Even though this information is not visible on opening, migrating the 
drawing should still convert the objects and they should display. 
 
Issue: 

Hatches added to Planting Areas disappear. 
Solution: 
To allow us to make use of the AutoCAD gradient hatches, we have had to remove 
the feature to hatch a planting bed from within the Planting Area dialog. Use the 
AutoCAD Hatch command to select and re-hatch the areas with the former or new 
gradient hatches. Set the Hatch option to create as “Separate hatches” if you require 
each bed to have its own individual hatch 
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Issue: 
All Partial Schedules are converted to Full Schedules 
Solution: 
Schedule Sub-sets of legacy (FP) drawings have now been replaced by Partial 
Schedules. As the sub sets were stored on the database, not the drawing as with 
the latest version, we are not able to recreate the plants that formally defined the 
subset and so replace the subsets schedule with a full schedule inserted in the 
same location. To redefine the partial schedule, modify the full schedule through 
Softworks>Schedule Display>Modify/ Set Style or by double clicking on the 
schedule, select [Partial Schedule] and reselect the specifications (tags) that should 
be included within the partial schedule. Repeat for each partial schedule 
 
Issue: 

Schedules change appearance 
Solution: 
Schedule templates of legacy (FP) drawings were stored on the database. In the 
new version these are defined by Schedule Styles and are now saved with the 
drawing. During conversion KeySCAPE creates a Schedule Style (Legacy Schedule 
Style) that is applied to any migrated schedule. As the former template is not 
available during migration, it can mean that some columns will disappear and others 
could change position and / or name. To rectify this you can format the schedule 
display using the Softworks->Schedule Display->Styles command as explained later 
in this section. 
 

Bed Schedules now include plants that have not been allocated a plot number  
Solution: 
In legacy (FP) drawings it was possible to miss a plant(s) when assigning plot 
numbers and there was no easy means of knowing this. In the latest version we 
now show you all the specifications that have not been allocated a plot number as 
“No Plot”. If you wish KeySCAPE to ignore these unassigned plots, from 
Softworks>Schedule Display>Schedule Styles pick the Bed No cell and on the 

Schedule Group Properties tab tick the option to Ignore objects with no plot, see 
below:  
 

 
 
 
Issue: 
The “tag” position shifts location 
Solution: 
Any change in location is likely to be un-noticeable or minimal. If this is an issue, 
using  grips, move the text location and/or leader to the position required 
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Issue: 
Old “tags” disappear or seem to disappear 
Solution: 
Whilst every attempt has been made to capture and convert legacy planting objects 
and tags to the new format objects, in some circumstances, planting areas and 
hedge graphics and/or specifications may not be converted and deleted or are 
converted and do not display correctly. This is usually a result of inappropriate 
labelling or damaged geometry in the legacy version, resulting in a zero number of 
plants when calculated. If you are able to modify the object, you can reselect the 
length or area to recalculate the plant numbers. Redefine the specification location 
and leader, as required. In the event that you are not able to modify the entity 
please delete and reinsert it as appropriate or contact Key Systems technical 
support for further assistance. 
 

IMPORTANT: You are advised to check the drawing after migration to identify 
where, if any, discrepancies have occurred. If you are unable to resolve these with 
the solutions described above, please contact Key Systems technical support for 

further assistance. 
 
Issue: 

During the update, KeySCAPE will create a temporary .KMI file. These files are 
typically deleted after conversion but if this fails or you choose not to convert 

the files they will remain on the users system. 
Solution: 
The temporary KeySCAPE file(s) created during the convert or Update Drawing 

command will be named [Drawing Name].kmi and can be located and deleted from 
the current users temporary windows folder, typically located at: 
 

            C:\Documents and Settings\[Current User]\Local Settings\Temp  
 
 
 
 

Creating your 
own 

Vegetation 

Symbol  

 

KeySCAPE provides you with the facility to quickly create and add new symbols to 
the system, allowing you to develop your own graphic style for your drawings. You 
can add graphics to the specific symbol types, e.g. trees, benches, arrows, etc, to 
expand the default palettes. Also, KeySCAPE includes three blank Project Symbol 
libraries where you can add, and quickly retrieve, your own preferred graphics. 

 
Drawing the Symbol 
 

  From the File menu select New to start a new (Blank) drawing based on 
the ACADISO.dwt (AutoCAD metric) template or KSLTOSO.dwt 
(KeySCAPE LT metric) template. 

  From the Draw pulldown menu, select Circle>Centre, Radius 

  When requested at the command prompt to Specify center point for 
circle, enter 0,0. 

 
This will put the centre of the circle at the co-ordinate 0,0, the insertion reference 
point used when it is inserted in a KeySCAPE drawing later. 

  

  When requested at the command prompt to Specify radius of circle or 
[Diameter], enter (a radius of) 0.5. 

 
This will create a 1-unit diameter circle. This means that when it is inserted in to a 
drawing, you can define the spread of the vegetation drawing and the symbol will 
scale correctly. 

 

  From View>Zoom menu select Extents. The circle will now fill the 
drawing editor.  

 
If the circle looks angular, from View menu select Regen to refresh the display and 
smooth the circle. 
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  From Format>Layer, create a new layer called T_plan_01 and assign 
the colour 64, or other required, to the new layer.  

  Make the layer T_plan_01 Current. Pick [OK]. 

  Create, using AutoCAD’s drawing tools, your own unique vegetation 
drawing using the construction circle as a guide, e.g. 

                      
  Once the symbol is defined, erase the construction circle used to define 

the drawing extents. 

  From View>Zoom select Extents. The symbol will now fill the drawing 
editor. 

  When you have created your symbol, select File>Save and navigate to 
the directory: 

 
       C:\KeySCAPE Systems Application Data\ 
              All Users\ 
                  KeyCORE\ 
                       Symbols\ 
                            Project 1\ 
                                Plan\ 
                                    Vegetation 

  For the drawing name, enter Mytree, or other name as required, and 
select Save. Close the drawing 

  The vegetation symbol will be added to the Project 1 Symbol Library. 
 
Alternatively, you can save the drawing in the corresponding folder under Trees 
(typically Symbols\Trees\Plan\Vegetation) and it will then appear in the Trees 
symbol selector dialog within KeySCAPE next time you insert a tree symbol. 
 

 Using your New Symbol 
 

   Open the drawing into which you wish to insert the new symbol. 

  From Core, select Project Libraries>Project 1. The Project 1 dialog 
appears. 

  Select the Plan tab to display your plan symbol. 
  Double-click the image icon. You are returned to the drawing editor. 
  At the command line you are prompted: 
 

                 Insertion Point:                    (Pick the insertion point of the tree) 
                 Spread:                               (Enter the spread of the tree) 
                 Height:                                (Enter the height of the tree) 

                 Rotation:                             (Enter the rotation for the tree) 
 

  The vegetation symbol you created will now appear in the drawing. 
 

The symbol created will remain in the project library unless you choose to delete it 
using Windows Explorer.  
 
KeySCAPE contains 3 project libraries. These allow you to create and add your own 
graphics to the system to build up your own palette of symbols for quick access to 
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your preferred symbols. These can be accessed, as described above, or by using 
the shortcut keys: 
                                      P1 - Project 1 

                                      P2 - Project 2 

                                      P3 - Project 3 
 

Creating your 

own 

Vegetation 
Edge Pattern  

 

KeySCAPE now provides you with the facility to quickly create and add new line 
patterns for use with hedges and planting areas, allowing you to develop your own 
graphic style for your drawings. 

 

Drawing the Pattern 
 

  From the File menu select New to start a new (Blank) drawing based on 
the ACADISO.dwt (AutoCAD metric) template or KSLTISO.dwt 
(KeySCAPE LT metric) template. 

  From the Draw pulldown menu, select Line. 
  When requested at the command prompt to Specify first point: pick a 

point on the screen where you wish to start drawing the line. This point 

does not need to be 0,0. 

  When requested at the command prompt to Specify next point or 

[Undo]: enter @1,0. and press Return. This will draw a construction 
line 1 unit in the X and 0 in the Y. 

  Press Return to complete the line command. 

  From View>Zoom, select Extents. The line will now fill the drawing 
editor. 

  This (construction) line will provide a template that ensures that the 
pattern scale and start point is set correctly. 

  Create a new layer, e.g. KST_PATTERN_01 and make the new layer 
Current.  

  Pick [OK]. 
 
IMPORTANT – Patterns MUST be drawn in metres, fit within 1 drawing 
unit, and must comprise of only polylines or arc-segmented polylines but 
NOT arcs, lines or circles.  
 

  From the Draw toolbar, select Polyline. 

  Using the construction line as a guide, draw the required pattern so that 
the polyline fits between the start and endpoints of the line. 

 
 
The pattern can be created from several polylines. These polylines do not need to 
start and end on the endpoints of the construction line but this will create gaps in the 
graphics when used later in the drawing. 

 

  When the pattern is complete, you can convert it into a new pattern.  
 
Converting the Drawing into a Pattern 
 

  From the Softworks pulldown menu, select Pattern Manager. The 
Pattern Manager dialog will appear. 
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  Pick [New].  You are returned to the drawing. 

  At the command line prompt to Select Objects: pick the polylines that 
defines the pattern, excluding the contraction line, although this should 
be filtered out, as it is a line not a polyline. 

  At the command line prompt to Select Pattern Origin:, using the 
OSNAP Endpoint, pick the end of the line at the start of the pattern 
(furthest left). The Pattern Name dialog appears.  

 
You do not need to define the other end of the pattern as KeySCAPE assumes the 
length of the pattern is I unit, hence the purpose of the original construction line. 

 

      
 

  Enter a new name for the pattern, e.g. KST Pattern. 

  Pick [OK]. The Pattern Manager dialog will reappear and the pattern 
will be displayed in the list. 

  Pick [Finished] to complete the creation of the pattern. 
 

Saving the Pattern to Create a Preview Thumbnail  
 

  Delete the construction line used to define the extents of the pattern but 
NOT the polylines that define the pattern. 

  From View>Zoom, select Extents so the pattern fills the screen. 

  From File select Save. The Save dialog appears. 

  From the Save in dropdown list (top of dialog), navigate to the softworks 
edge pattern folders, typically: 

 
              C:\KeySCAPE Systems Application Data\ 
                    All Users\ 
                      KeySOFTWORKS\ 
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                        Symbols\Patterns\ 
                          Softworks Edges\ 
                            Select Only 
 

  Enter the name for the drawing name which MUST be the same name 
as the pattern defined above, e.g. KST Pattern. 

  This will create a drawing (preview thumbnail) in the Patterns selection 
dialog. 

 
Using your New Pattern  
 

  Use the patterns you define when adding or modifying either a Planting 
Area or Hedge. See Section 2 for information on creating and modifying 
Hedges and Planting Areas. 

 
 

Plant Lists When preparing to specify a drawing, it can be very productive to create a plant list 
(palette) of your most frequently specified plants from the start. This will prevent the 
need to continually define the specification, especially when the labelling extends 
across several editing sessions, drawings or projects. The information within a plant 
list is often user or company specific so, for example, it may be desirable to 
establish your list based on: preferred nursery stock, a named supplier, a specific 
client or a project type, such as technology parks or school grounds. How you 
categorise these is up to you to define but creating a plant list from which to specify 
(select) will save you time on specific and general projects. Plant lists can be used 

as a template to create new plant lists or can be created from imported data. 
 
Creating a Plant List File 
 

  From the Softworks pulldown menu, select Database Manager. The 

Database Manager dialog box will appear. Pick on the Plant List tab.  
 
       

 
 
The dialog lists both Plant List Groups (left-hand side) and Plant Lists (right-hand 
side) contained within the groups. Groups are similar to folders and can contain 
many plant list files. You can create additional groups as follows: 
 
Adding a New Plant List Group 
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  Under Groups (left-hand window) pick [Modify], or right-click in the 
Groups window, and a pop-up will appear. 

 

  Pick Add Plant List Group. The New Plant List Groups dialog 
appears. 

 

       
 

  Enter a new name for the plant list group, e.g. KST Group. 

  Pick [OK] to accept and create the new group. 
 
Adding a New Plant List File to a Plant List Group 
 

  Select the Group in to which you wish to add your new plant list file. 

  Under Plant Lists (right-hand window) pick [Modify], or right-click in the 
Plant List window. A pop-up menu will appear.  

       

       
 

  Select Add Plant List from the list. The Add New Planting List dialog 
box will appear. 
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  Next to List Name, enter the unique name for the new plant list, e.g. 
Test List 

  If you wish to enter a description, to help identify the purpose or use of 
the plant list, this can be entered in the window adjacent to List 
Description, e.g. This is a test Plant List 

  To add a plant to the plant list, select [Specification]. The Plant 
Specification dialog will appear. 
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  Specify the plant, as described in Section 2, depending on whether you 
are specifying a single species plant for use as a specimen, planting 
area or hedge. 

  When specified, pick [OK]. 
 
For speed and consistency, It may be desirable, but not critical, to define a density 
for each plant at this stage to prevent needing to specify it each time the plant is 
selected from the list. Specimen trees do not need to have a density as the numbers 
will be calculated based on the number of incidences in the drawing.. 

 

  Under Layout Type, from the dropdown list pick a density type for the 
plant, where density equals either /m

2
 or /lin.m, depending on whether 

the plant is used within a planting area or as part of a hedge. 

  Under Density, enter a density for the plant. 

  Under Price, enter a price for the plant specification you have defined. 
This price is for budgetary purposes so you can enter the price that is 
appropriate to you, e.g. supply only, supply and plant or prepare, supply, plant 
and maintain for twelve months. See Price Manager later in this section for 
more information on pricing drawings. 
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  When specified, select [Add] to include the plant in the plant list. 

  Repeat the above process to add more plants to the list and so build up 
your plant palette.  

 
There is no limit to the number of species that can be included in a plant list and it 
can contain plants from all the species groups, if required. In this instance, you can 
use the group filter above the Species column to show only plants from certain plant 
groups, e.g. Trees within the list. 

 

  When your plant list is complete, pick [OK] to add the new plant list 
named Test List to the Custom group. 

 
If you have not named or given the Plant List a unique name, you will be prompted 
to do so and returned to the dialog. 
 

       
 

All plant list files are automatically saved within the KeySCAPE database for use at 
any time in the future. For this reason it is important that your Softworks database is 

backed up. See Managing the KeySCAPE Database, later in this section. 

 
 
 



Key Systems Advanced Softworks Features 

 

KeySCAPE Design Studio Tutorial 
SCAPE Section3Rev5 

.DOC Revision0       3-15 
 

 

Modifying a Plant List File 
 

  From the Softworks pulldown menu, select Database Manager. The 
Database Manager dialog will appear. 

  Select the Plant Lists tab to show all Plant Lists groups currently 
defined on your database. 

  Under Groups, pick on the group that includes the Plant List file you 
wish to modify. 

  Under Plant Lists, pick the Plant List you wish to modify.  

  Pick [Modify]. A pop-up list will appear. 

  Pick View/Edit Plant List. The Modify Plant List dialog appears.  
 

       
 

  Select the plant you wish to modify from the list. The plants information 
will display under Plant Specification (top of the dialog). 

  You can now modify the selected plant specification in the following 
ways: 

 
o To update the Plant Specification – pick [Specification], in the 

Specification Select dialog make the necessary changes to the 
specification and then return to the Modify Plant List dialog. Pick 
[Update] and the selected plants specification will be updated. 

 
o To update the Plant Density – redefine the Layout Type and/or 

the planting density as necessary and pick [Update]. The selected 
plants density will be updated. 

 
o To remove a Plant Specification – pick [Remove] and the 

selected plant will disappear from the plant list. 
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  Pick [OK] to accept the changes or [Cancel] to undo all changes.  
 
 

Creating a Copy of a Plant List File 
 
Rather than modifying an existing working plant list file, you may wish to make a 
copy of the file, i.e. Save As, or may wish to use one plant list file as a template to 
create another plant list. 
 

  From the Softworks pulldown menu, select Database Manager. The 
Database Manager dialog will appear. 

  Select the Plant Lists tab to show all Plant Lists groups currently 
defined on your database. 

  Under Groups, pick on the group that includes the Plant List file you 
wish to copy. 

  Under Plant Lists, pick the Plant List you wish to Copy.  

  Pick [Modify]. A pop-up list will appear. 

  Pick Copy Plant List As… The Copy Plant List dialog appears. 
 

       
 

  Enter a new name for the Plant List as required. 

  Pick [OK] and the new Plant List will appear in the list. 
 

 Importing a Plant List 
 
Many designers have preferred suppliers of plant material or use plant selector 
software. If this information is available in a digital format, you can import it as a new 
Plant List. 

 
Please ensure the source plant list data is saved in one of the following formats: 
                  PlantPARTNER (.ksp) 
                  Helios (.ksc) 
                  Microsoft Access (mdb) 
                  Microsoft Excel (xls) 
                  Comma Separated Value (csv) 
 

IMPORTANT: Please ensure that the data for Microsoft Access, Microsoft Excel 

and CSV is checked and formatted correctly before you import it into a new Plant 
List. Whilst not critical, it can be helpful to separate out the import file(s) into distinct 
plant group types i.e. trees, shrubs, etc., as this can significantly speed up the import 
process and result in fewer mistakes.  
 
For each of the formats above you should separate the data as follows: 
 

Microsoft Access – Create each group type in its own appropriately named 
table, e.g. trees, shrubs, etc. The first line of the table should include the 
appropriate headers, e.g. Species Name, Common Name, etc. (Only Access 97 
or later file formats are supported) 
 

Microsoft Excel – Create each group type in its own appropriately named 
worksheet, e.g. trees, shrubs, etc. The first line of the worksheet should include 
the appropriate headers, e.g. Species Name, Common Name, etc. (Only Excel 
97 or later file formats are supported) 
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CSV – create each group type as a separate, appropriately named file, e.g. 
trees, shrubs, etc. The first line of the text file should list, in the correct order, the 
appropriate headers for the data contained within the file, e.g. Species Name, 
Common Name, etc. 
 

PlantPARTNER and Helios – No formatting required. See next section 

 
 

  From the Softworks pulldown menu, select Database Manager. The 
Database Manager dialog will appear. 

  Select the Plant Lists tab to show all Plant Lists groups currently 
defined on your database. 

  Under Groups, pick on the group into which you wish to import the new 
Plant List, e.g. Custom 

 

       

 
You can create your own Plant List Group to import in to as described previously. 

 
 
Importing a Plant List from MS Excel or MS Access 
 
Only Excel and Access files saved in 97 or later file formats are supported. 
 

  From the Softworks pulldown menu, select Database Manager. The 
Database Manager dialog box will appear. Pick on the Plant List tab.  

  Under Groups, pick the Group in to which you wish to import the Plant 
List file.  

  Under Plant Lists, pick [Modify] and from the pop-up list select Import 

Plant List. The Open dialog appears.  

  Navigate to the Tutorial\Files folder and pick and open the file KST 

Excel Plant List.xls (an MS Excel file). As the file contains multiple 
worksheets (or tables if in MS Access), the Select Table dialog appears 
listing all available worksheets contained within the file. 
 

       



Key Systems Advanced Softworks Features 

 

KeySCAPE Design Studio Tutorial 
SCAPE Section3Rev5 

.DOC Revision0       3-18 
 

 
 
The Excel file has been formatted so that all the tree information is contained within 
the Trees worksheet and all the shrub specifications have been saved on a Shrubs 
worksheet. You may wish to open the file in Excel to see this formatting. 
 

  Pick on the Shrubs table and pick OK. The Import dialog will appear. 
 

  
 
Under Select Fields, the right-hand column (Imported Fields) lists all the column 
names, based on the header text in the Excel file, whilst the left-hand column 
(Standard Fields) allows you to define where, in the KeySCAPE database, you wish 
this information to be inserted, i.e. to match the contents of the imported database 

file with the structure of the KeySCAPE database. Under Select Rows to Import, is 
a preview of the rows and their data, defined within the Excel file and allows you to 
select which rows (data) are to be included or excluded from the import. 

 

  In the window adjacent to Plant List Name, enter a unique name for the 
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new, imported plant list, e.g. Test Import from Excel 
  Under Select Fields>Imported Fields, next to Shrubs, pick on the 

drop-down list under Standard Fields and select Name, i.e. the column 

Shrubs contains the scientific names of plants that you wish to import into the 
Name column within the KeySCAPE database. 

  Match the remaining data as follows: 
 

       

 

Only if the data is required for the import do you need to “match” to the KeySCAPE 
database, so if a column is empty (e.g. the Diameter column does not contain any 
data), you do not necessarily need to select a matching field in the KeySCAPE 
database. Also, if you wish to add supplementary specification data not included 
within the KeySCAPE database, you can assign these multiple columns to the 
Specification field. 

 

  Under Select Rows to Import, pick the rows you wish to import using 
the standard windows selection methods, namely: 

 
                     Ctrl+a – selects all records 
                     Ctrl+mouse pick – selects/deselects individual records 
                     Shift+mouse pick – selects all records between first and 
                                                     second pick  
 
      

 
 

  Pick OK and the import of selected plant specifications will begin. 

  If a species appears in the imported list that does not already exist on 
the KeySCAPE database, the Select Species Group dialog appears.  
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  For each plant in the list you must assign a species group by selecting 
from each drop-down list under the Species Group column. This will 
determine into which group the plant will appear when it appears in the 
plant schedule. 

 
      

 
 
WARNING – You will not be able to proceed with the import until all plants are 
appropriately allocated. Selecting Cancel will stop the import completely. 

 

  Once defined, pick OK to complete the import and return to the 
Database Manager dialog. 

 
 

 Importing a Plant List from a .CSV File 
 

  From the Softworks pulldown menu, select Database Manager. The 
Database Manager dialog box will appear. Pick on the Plant List tab. 

  Under Groups, pick on the Group into which you wish to import the new 
Plant List, e.g. Custom 

  Under Plant Lists, pick [Modify] and from the pop-up list select Import 

Plant List. The Open dialog appears.  

  Navigate to the Tutorial\Files folder and pick and open the file KST 

Plant List.csv, a comma separated file where each record is separated 
by a comma. The Import dialog will appear. 
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The file has not been formatted so all the tree and shrub specifications have been 
saved in a single list. You may wish to open the file in Notepad to see this 
formatting.  
 

Partial Import of the list to only select trees 

 
The data in the file does not correctly match the requirements of the import as the 
column Girth/Diameter includes both sets of data.  You do not wish the data for 
girths to go into the list for diameter or vice versa. If the data for Girth and Diameter 
is in distinct columns, you can import as one file but if they are combined, as here, 
you will need to select only part of the list to import and repeat for each section of 
the import. 
 

  In the window adjacent to Plant List Name, enter a unique name for the 
new, imported plant list, e.g. Test Import from CSV 

  Under Select Fields>Imported Fields, next to Species, pick on the 

drop-down list under Standard Fields and select Name. 

  Match the remaining data, as follows: 
 

       

 

  Under Select Rows to Import, only pick the rows you wish to import, 
namely the tree species, excluding the header text, otherwise this WILL 
be imported as a new species name during the import. 
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  Pick OK and the import of the plant list will begin. 
 
If a species name appears in the imported list that does not exist on the KeySCAPE 

database, the Select Species Group dialog will appear and you will be required to 
assign each plant to the appropriate group, i.e. Trees. 
.         

  Once complete the new plant list will appear in the Database Manager 
dialog.  

  Repeat the above process but this time select only the shrubs to import 
 
 

 Importing a Plant List from PlantPARTNER or Helios 
 
Users of PlantPARTNER and Helios can export their schedules/plant palettes, 
containing different plant types, e.g. trees, shrubs, etc and import the file directly into 
KeySCAPE without the need to match the import data. For further information on 

these products please visit www.plantpartner.co.uk or www.gohelios.co.uk, 
respectively 

 

  From the Softworks pulldown menu, select Database Manager. The 
Database Manager dialog box will appear. Pick on the Plant List tab.  

  Under Groups, pick on the group into which you wish to import the new 
Plant List, e.g. Custom. 

  Under Plant Lists, pick [Modify] and from the pop-up list select Import 
Plant List. The Open dialog appears.  

  Navigate to the Tutorial\Files folder and pick and open the file, e.g. 
KST_PlantPARTNER.ksp, a PlantPARTNER file 

 
PlantPARTNER exports to KeySCAPE using the .KSP file name extension whilst 

Helios exports to KeySCAPE using the .KSC file name extension. 
 

  Pick OK. The file will be read directly into the KeySCAPE Plant List dialog, 

defaulting to the name of the original file, and will appear under the selected 
Group. You can rename the Plant List name, as below. 

 

Renaming a Plant List Group or Plant List File 
 

  From the Softworks pulldown menu, select Database Manager. The 
Database Manager dialog box will appear. Pick on the Plant List tab.  

  Under Groups or Plant Lists, pick on the group or Plant List you wish 
to rename. 

  Under the relevant window, pick [Modify] and from the pop-up list select 
Rename. The Edit Group or Edit Plant List dialog will appear.  
 

        
 

  Enter a new name for the Group or Plant List and pick [OK] to confirm 
the change. 

 
Deleting a Plant List Group or Plant List File 
 

  From the Softworks pulldown menu, select Database Manager. The 

Database Manager dialog box will appear. Pick on the Plant List tab.  
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  Under Groups or Plant Lists, pick on the group or Plant List you wish 
to delete. 

  Under the relevant window, pick [Modify] and from the pop-up list select 
Delete. The KeySOFTWORKS dialog will appear asking you to confirm 
your choice. 

 

        
 
CAUTION: There is no Undo or Cancel to allow you to retrieve deleted Plant Lists or 
Plant List Groups so be sure of your selection before you confirm the deletion. 
Deleting a Plant List Group will delete all Plant Lists within the selected group 

 

  Pick [Yes] to confirm the deletion of the Group or Plant List. 
 
 

Exporting a Plant List File 
 

You may wish to export a Plant List in order to: share data with other KeySCAPE 
users; be able to open the list in a word processor or spreadsheet; or to archive with 
the drawing/project. 

 

  From the Softworks pulldown menu, select Database Manager. The 

Database Manager dialog box will appear. Pick on the Plant List tab.  

  Under Groups, pick the group that contain the Plant List you wish to 
export. 

  Under Plant Lists, pick on the Plant List you wish to export. 

  Under the Plant Lists window, pick [Modify]  

  From the pop-up list select Export Plant List. The Save As dialog will 
appear requiring you to define where you wish to export the file.  

 

       
 
The file name defaults to the same name as the selected Plant List but can be 

changed. 
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  Pick [Save] to confirm export of the Plant List. 
 
All Plant List exports are saved in a .CSV (comma separates value) file format and 
can be imported as defined in the previous section for Importing a Plant List from a 
.CSV File. Also, these files can be opened in word processor or spreadsheet 
software. 

 
 

Specifying from a Plant List File (Single Species only) 
 

You can use a Plant List to specify any single species plant, i.e. specimen, planting 
area, hedge. It can also be used as a reference for plant specifications to be 
included in other Plant Lists or mix file See Section 2 for information on plant mixes. 

 

Using a Plant List File to Specify a Plant e.g. Specimen. 
 

  From the Softworks pulldown menu, select Specimen>Add. The 

Specimen dialog will appear.  

  Pick the radio button next to Insert New Specimen. This activates this 
area of the dialog for editing. 

 

 
 

  Pick in the edit (white) box next to Spread and type in a value of 3. 

  Pick in the edit box next to Height and type in a value of 3. 

  Pick on the [Insert<] button. The Trees dialog will appear.  

  In the Trees Symbol Selector dialog, double pick the tree symbol you 
wish to add. You will now be returned to the drawing. 

  You are prompted for Symbol Insertion Point:  

  Insert the symbols as required. Press Return to return to the Add 
Specimen dialog. 

  Pick [Specification]. The Specification Select dialog box appears.  

  Pick the Plant List tab. The Plant List groups appear. 

  Select the Plant List Group containing the Plant List you wish to use. 
The Plant List files appear. 

  Select the Plant List file you wish to use. The contents of the Plant List 
appear below. 

  Select the required plant from the list.  
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  Pick [OK] and the selected plant information will populate the 
specification area of the Specimen dialog. 

  Pick [OK]. 

  You will be prompted at the command line to Select Info Location:  

  Pick a point on the screen where you wish the specification information 
(plant label) to appear. 

  You are prompted to Select Fixed LeaderPoint or [<eXit>]:.  

  Pick points to define the start of the leader line, typically starting at the 
specimen(s) and working back to the specification, pick additional 
leader points to define the leader.  

  When complete press Return. The specification and leader will be 
inserted. 

 
Repeat the above process to select other single species plants when specifying 
specimens, hedges or planting areas. 

 

  

Layered 

Planting 

In Section 2 it was demonstrated how to use either a single species or mix planting 
to specify a planting area. However, in some cases you may wish to structure a 
planting area by “layering” the plants/mixes and specifying plants at different 
densities to suit their purpose, i.e. over/under planting. This would not be possible if 
planted as a Full Coverage Mix as this only allows you to specify a single density. 
You can create layered planting, as follows 
 

  From the Softworks pulldown menu, select Planting Area>Add or 
Modify, depending on whether you are adding a new planting area or 

modifying an existing one. 

  The Add or Modify Planting Area dialog appears, respectively. 
 
You can specify the first specification layer as described in Section 2, e.g. 

 

  Under Specification, pick [Set Single Species/Mix ->]. A drop-down 
list appears with the following specification layout options: 
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o Full Coverage - Single Species: allows you to assign a single species 

specification to the entire area 
o Full Coverage – Mix: allows you to assign a single mix specification to 

the entire area 
o Percent of Area - Single Species: allows you to assign a single 

species specification to a percentage of the area, i.e. the specified plant 
does not fill the entire area.  

o Percent of Area – Mix: allows you to assign a mix specification to a 

percentage of the area, i.e. the specified mix does not fill the entire area.  
 

  On the current Specification tab, next to Header, you can optionally 
enter the text you wish to appear, as a header, above the new layer 
when the specification text (label) is inserted in the drawing, e.g. Canopy 

Layer. 
 
Once the first plant specification layer is defined, you can now add other planting 
layers, as follows: 
 

  Under Specification, pick [Add Single Species/Mix ->]. A drop-down 
list appears with the following specification layout options: 

 

       
 

o Full Coverage - Single Species 
o Full Coverage – Mix 
o Percent of Area - Single Species 
o Percent of Area – Mix 
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Full Coverage - Single Species 
 
Allows you to assign a new single species specification to the entire area, i.e. you 
wish to plant the same area again with a new plant. This would be useful where you 
wish to over/under plant an existing specified planting area with a new, full coverage 
plant at a density that can be different to the first plant specification, e.g. structural 
planting, ground cover or a bulb. 

 

  Under Specification, pick [Add Single Species/Mix ->]. From the 
drop-down list pick Full Coverage - Single Species. A new Full 
Coverage single species specification tab appears. 
 

       
 

  Specify the new single species plant and density as described in 
Section 2. 

  Next to Header, you can optionally enter the text you wish to appear, as 
a header, above the new layer when the specification text (label) is 
inserted in the drawing, e.g. Under Storey Planting. 

  Next to Subtract m
2
 per plant (see below), you can optionally enter the 

area around each plant you wish to be excluded (deducted).from the 
next layer. 

 
Subtract m

2
 per  

 
Due to the root zone/ball that exists around each plant when planted, by necessity, 
each plant will take up some of the available area for the next layer. This can be 
(optionally) factored for by setting an area around each plant that is to be deducted 
from the total area available at the next layer, e.g. if a 2L pot has a surface area of 
0.15 m

2 
and the plant is being planted at a density of 3/m

2 
the area left for planting at 

the next level will be only 0.55 m
2
 for every m

2 
to be planted. 

 
  Next to Subtract m

2
 per plant, enter the area around each plant you 

wish to exclude (deduct). 

  The area available for the next layer will be reduced, as will the number 
calculation of plants, to reflect the reduction in available planting area, 
as a factor of the current density. 

 
For example: 
Layer 1:         Total area                        = 100 m2

  
                      Density                            = 1/m

2 

                      Subtract m2 per plant     = 0.3/m
2 

 
Layer 2:         Total area available        = 70 m

2
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Full Coverage - Mix 
 
Allows you to assign a new single mix specification to the entire area, i.e. you wish 
to plant the same area again with a new Mix. This would be useful where you wish 
to over/under plant an existing specified planting area with a new, full coverage mix 
at a density that can be different to the first plant specification, e.g. under 
storey/ground cover planting or a bulb mix. 

 

  Under Specification, pick [Add Single Species/Mix ->]. From the 

drop-down list pick Full Coverage - Mix. A new Full Coverage Mix 
specification tab appears. 

 

        
 

  Specify the new mix file and density as described in Section 2. 

  Next to Header, you can optionally enter the text you wish to appear, as 
a header, above the new layer when the specification text (label) is 
inserted in the drawing, e.g. Ground Cover Mix. 

  Next to Subtract m
2
 per plant, you can optionally enter the area 

around each plant you wish to be excluded (deducted).from the next 
layer. 

 
Percent of Area - Single Species 
 
Allows you to assign a new single species specification to a percentage of the area, 
i.e. the specified plant does not fill the entire area. This would be useful where you 
wish to add a new single species to an existing specified planting area but at a 
different density, i.e. you may wish to specify the canopy, under storey and ground 
cover planting at different densities. This is not possible if planted as a Full 
Coverage Single Species or Mix as only one density is permitted. 

 

  Under Specification, pick [Add Single Species/Mix ->]. From the 

drop-down list pick Percent of Area – Single Species. A new 2 - 
0.00% (specification) tab appears. 
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  Specify the new mix file and density as described in Section 2. 

  Next to Header, you can optionally enter the text you wish to appear as 
a header above the new layer, when the specification text (label) is 
inserted in the drawing, e.g. Under Storey Planting. 

  Next to Subtract m
2
 per plant, you can optionally enter the area 

around each plant you wish to be excluded (deducted).from the next 
layer. 

  Next to % of Area (see below), enter the percentage the single species 
will constitute of the total area 

 
Ideally, but not critically, the first specification tab would also be defined as a percent 
of area so the available area for the new layer could be less than the total area. You 

can define the areas available for each and subsequent levels using either Subtract 

m2 per plant (see earlier in section) or % of Area, as below: 

% of Area 
 

Allows you to define the area available for each layer as a percentage of the total 
area. The total percentage for all the specification layers can not exceed 100%. 

 

  Next to % of Area, enter the percent the new single species will 
constitute of the total area, e.g. 25 % of the total area.  

  The number of plants will update to reflect the reduction in available 
planting area, as a factor of the current density. 

 
For example: 
Layer 1:         Total area                        = 100 m2

  
                      % of Area                        = 75 
                      Density                            = 1/m

2
 

                     Total number of plants     = 75 
 
Layer 2:         Total area                        = 100 m2

  
                      % of Area                        = 25 
                      Density                            = 3/m

2
 

                     Total number of plants     = 75 
 

     
Percent of Area - Mix 
 
Allows you to assign a new mix specification to a percentage of the area, i.e. the 
specified mix does not fill the entire area. This would be useful where you wish to 
add a new mix to an existing specified planting area but at a different density, i.e. 
you may wish to specify the canopy, under storey and ground cover mix planting at 
different densities. This is not possible if planted as a Full Coverage Mix as only one 
density is permitted. 
 

  Under Specification, pick [Add Single Species/Mix ->]. From the 

drop-down list pick Percent of Area – Mix. A new Spec. 2 - 0.00% Mix 
(specification) tab appears. 
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  Specify the new mix file and density as described in Section 2. 

  Next to Header, you can optionally enter the text you wish to appear as 
a header above the new layer, when the specification text (label) is 
inserted in the drawing, e.g. Under Storey Planting. 

  Next to % of Area, enter the percentage the mix will constitute of the 
total area. 

  The number of plants will update to reflect the reduction in available 
planting area, as a factor of the current density. 

  Next to Subtract m
2
 per plant, you can optionally enter the area 

around each plant you wish to be excluded (deducted).from the next 
layer. 

 
Specify additional specification layers, using any combinations of the above layer 
types, to build the structure of your “Layered Planting”   

  

Specification Options 
 
Allows you to manage the planting layers associated with the planting area. The 
following options exist:   
 

  Under Specification, pick [Specification Options->]. A drop-down list 
appears with the following specification layer options: 

 

       
 

o Move Left (Up): allows you to move the position of the current 

specification layer to the left. This will move its position up the list when the 
specification text (label) is inserted in the drawing. 

o Move Right (Down): allows you to move the position of the current 

specification layer to the right. This will move its position down the list when 
the specification text (label) is inserted in the drawing. 

o Remove Selected: allows you to remove current layer from the planting 

area specification.. 
o Remove All: allows you to remove all layers from the planting area 

specification. 
 
 
 

Managing the 
Softworks 

Database 
 

Database Location, Sharing and Back Up 
 
Unless defined elsewhere during installation, the KeySCAPE Softworks database 

(KSW_Database.mdb) is typically installed and located in the folder: 
 

C:\KeySCAPE Systems Application Data\ All Users \ KeySOFTWORKS\ Database\.  
 

As the database contains all your customised information, e.g. mix files, plant lists, 
etc., you are recommended to regularly back this up or move the default location to 
a network location where it can be backed up on a regular basis and/or can be 
shared by other KeySCAPE users.  

 

  Open Windows Explorer. 

  Copy the KeySCAPE Systems Application Data folder and all sub 
folders to a network location 
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  From the Start>Programs>KeySCAPE Systems, run Configure 

KeySCAPE for your application. The Configure KeySCAPE dialog 
appears 

 

       
 

  Under Application Options, pick [Set App. Data Root Dir]. The 
Browse for Folder dialog appears. 
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  Browse to and select the network location where you copied your 
KeySCAPE Systems Application Data folder.  

  Pick [OK] to return to the Configure dialog. 

  Pick [OK] to apply the change. 

  Reopen KeySCAPE. 

  Repeat the above process for ALL users that wish to share the 
network database either when logged on to the current computer or 
other computers. 

 
Whilst not recommended, you will note that flexibility exists to set different locations 
for individual folders contained within the KeySCAPE Systems Application Data 
folder. 
 

Repairing and Compacting the Database  
 
To maintain the performance of your database and repair any errors that may arise, 
it is recommended to compact and repair your database on a regular basis.  
 

  Close your copy of KeySCAPE or, if sharing a network database, close 
all copies of KeySCAPE. 

  From the Windows Desktop, pick Start>All Programs>KeySCAPE 
Systems> Your installed application (e.g. KeySCAPE Design Studio 

2007)>Database Repair. The KeySCAPE Systems Database Repair 
dialog appears. 

 

       
 

  If the path and database does not appear in the edit window, or is 

incorrectly defined, pick [Browse]. 

  Navigate to and select your KSW_Database.mdb file in the correct 

location. Pick [OK] to return to the KeySCAPE Systems Database 
Repair dialog 

  Pick [Compact and Repair]. When complete you will be notified (this 

may take a few seconds to complete): 
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  Close the dialogs and reopen KeySCAPE 
 
 

Update Database (Merging your former KeySCAPE Database)  
 
Users of KeySCAPE and KeyPLANTING may have customised data on their former 
database(s) and wish to have this information available on the new database, e.g. 
plant lists, mixes and preferred species. To add this to your new database, you must 
merge the old database with the new one, as follows: 
 

  From the Core pulldown menu, select Update Database. A message 
dialog appears.  

 

       
 

  Pick [Yes] to proceed. The Open dialog appears. 

  Navigate to and select your former database.  

  Pick [Open] and KeySCAPE will start merging (importing) your data. 

  This WILL take several minutes to complete and the progress indicator 
will show how long the process is taking. 

 
IMPORTANT: Should you minimise KeySCAPE or switch to another application 

whilst merging the data, the progress indicator will appear to stop. DO NOT stop the 
process but wait until you are notified that it is complete 

 

  You will be notified when the process is complete and your former plant 
lists, mixes and customised species will be available for selection on 
the new database 

 
IMPORTANT – The former KeySCAPE database did store your schedule templates. 
These DO NOT come across in the merge, as schedule templates are now 
managed by Schedule Styles (see later in this section). These are now defined by 
files on your system and once added reside in the drawing. Consequently, you will 
need to redefine your former schedule templates using schedule styles. Key 
Systems technical support can assist you with this process, if required. 

 
 
Modifying the Content of the Database 
 
For information regarding using the Database Manager to manage your Plant Lists 
and Mix files stored on the database, see the relevant section on Plant Lists, earlier 
in this section, and Mix files, within section 2. 
 

  From the Softworks pulldown menu, select Database Manager. The 

Database Manager dialog appears. 
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Adding or Modifying Plants on the Database 
 

  From the Species tab, pick the dropdown under Choose Species 
Group. The Species group list appears. 

       

        
 

  From the list select the species group that contains the data you wish to 
modify, e.g. Trees. The edit window below will un-grey. 

  Under Choose Field pick the dropdown list. The fields list will appear to 

show data that is available for editing within the selected species group. 
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  From the list select the field that contains the data you wish to modify, 
e.g. Species Name. The edit window below will un-grey. 

  Under Choose Field pick the dropdown list. The fields list will appear to 

show data that is available for editing within the selected species group. 

 

Adding a New Species to the Database 
 

  Under the species list, pick [Modify]. A pop-up list will appear 
 

       
 

  Pick Add. The New Data dialog appears. 
 

       
 

  Enter the new species name. Pick [OK] to add the new species to the 
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species list for the currently selected group, e.g. Trees. 
 
Modifying a Species on the Database 
 
Renaming a Species 
 

  Under the species list (left-hand side window) pick the plant you wish to 
modify and select [Modify]. From the pop-up list pick Edit. The Edit 
Data dialog appears. 

 

       
 

  Enter the new name. Pick [OK] to apply the change 

   
 
Removing a Species 
 

  Under the species list (left-hand side window) pick the plant you wish to 
remove and select [Modify]. From the pop-up list pick Delete. A 
warning dialog appears requiring you to confirm that you wish to delete 
the plant. 

 

       
 

  Pick [Yes] or [No], as appropriate. 
 
Adding an Abbreviation for a Species 
 

  Under the species list (left-hand side window) pick the plant that you wish 
to add an abbreviation.  The right-hand window will un-grey. 

 

Formatted: Bullets and

Numbering
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  Pick the Abbreviation radio button.  

  Under the abbreviation list (right-hand side window) pick [Modify]. From 
the pop-up list pick Add. The New Data dialog appears. 

  Enter the new abbreviation name. Pick [OK] to assign the new 
abbreviation to the selected species. 

 
You can assign multiple abbreviations to a species and these can be selected when 
specifying the plant as either a specimen, hedge or planting area 

 
Editing an Abbreviation assigned to a Species 
 

  Under the species list (left-hand side window) pick the plant you wish to 
modify. The right-hand window will un-grey. 

  Pick the Abbreviation radio button.  

  Under the abbreviation list (right-hand side window) pick [Modify]. From 
the pop-up list pick Edit. The Edit Data dialog appears. 

  Enter the new abbreviation name. Pick [OK] to update the abbreviation 
for the selected species. 

 
 
 
Removing an Abbreviation assigned to a Species 
 

  Under the species list (left-hand side window) pick the plant you wish to 
modify. The right-hand window will un-grey. 

  Pick the Abbreviation radio button.  

  Under the abbreviation list (right-hand side window) pick [Modify]. From 
the pop-up list pick Delete.  

  A warning dialog appears requiring you to confirm that you wish to 
delete the plant. 

  Pick [Yes] or [No], as appropriate. 
 
Adding a Common Name for a Species 
 

  Under the species list (left-hand side window) pick the plant that you wish 
to add an abbreviation. The right-hand window will un-grey. 

  Pick the Common Name radio button.  

  Under the Common Name list (right-hand side window) pick [Modify]. 
From the pop-up list pick Add. The New Data dialog appears. 
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  Enter the new common name. Pick [OK] to assign the new common 
name to the selected species. 

 
You can assign multiple Common Names to a species and these can be selected 
when specifying the plant as either a specimen, hedge or planting area 

 
Editing a Common Name assigned to a Species 
 

  Under the species list (left-hand side window) pick the plant you wish to 
modify. The right-hand window will un-grey. 

  Pick the Common Name radio button.  

  Under the common name list (right-hand side window) pick [Modify]. 
From the pop-up list pick Edit. The Edit Data dialog appears. 

  Enter the new common name. Pick [OK] to update the common name 
for the selected species. 

 
Removing an Abbreviation assigned to a Species 
 

  Under the species list (left-hand side window) pick the plant you wish to 
modify. The right-hand window will un-grey. 

  Pick the Common Name radio button.  

  Under the common name list (right-hand side window) pick [Modify]. 
From the pop-up list pick Delete.  

  A warning dialog appears requiring you to confirm that you wish to 
delete the plant. 

  Pick [Yes] or [No], as appropriate 
 
 
Modifying Specification Lists on the Database 
 
When specifying a specimen, hedge or planting area you can select from common 
lists defined in KeySCAPE that comply with the National Plant Specification (NPS). 
However, you can supplement these with your own specification items, if required. 

 

  From the Species tab, pick the dropdown under Choose Species 
Group. The Species group list appears. 

  From the list select the species group that contains the data you wish to 

modify, e.g. Trees. The edit window below will un-grey. 

  Under Choose Field pick the dropdown list. The fields list will appear to 
show data that is available for editing within the selected species group. 

  From the list select. Specification. The edit window below will un-grey. 
 
Adding a new Specification Category and Item to the database 
 

  Under the Specification list, pick [Modify]. A pop-up list will appear 
 



Key Systems Advanced Softworks Features 

 

KeySCAPE Design Studio Tutorial 
SCAPE Section3Rev5 

.DOC Revision0       3-39 
 

         
 

  Pick Add. The New Data Dialog appears. 
 

        
 

  Enter the name for the new category, e.g. Tutor. Pick [OK] to add the 
new category to the list. 

 
Adding a new Specification to Category on the database 
 

  Under the Specification list, pick [Modify]. A pop-up list will appear 

  Pick the category. The edit window on the right-hand side will un-grey.  

  Under the right-hand window, pick [Modify]. A pop-up list will appear 
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  Pick Add. The New Data Dialog appears. 
 

        
 

  Enter the name for the new specification data, e.g. Tutor 
Specification. 

  Pick [OK] to add the new specification to the Tutor category. 
 
You can assign multiple specification items to a category and these can be selected 
when specifying a plant as either a specimen, hedge or planting area 

 
Editing a Specification Category 
 

  Under the Specification list (left-hand side window) pick the category you 
wish to modify.  

  Pick [Modify]. From the pop-up list pick Edit. The Edit Data dialog 
appears. 

  Enter the new specification category name. Pick [OK] to update the 
category name for the selected species group. 

 
Editing a Specification Category Item  
 
  Under the Specification list (left-hand side window) pick the category 

containing the item you wish to modify. The edit window on the right-hand 

side will un-grey.  

  Pick the item you wish to modify from the list and pick [Modify]. From 
the pop-up list pick Edit. The Edit Data dialog appears. 

  Enter the new specification item. Pick [OK] to update the item for the 
selected category. 

 
Removing a Specification Category 
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  Under the Specification list (left-hand side window) pick the category you 
wish to delete.  

  Pick [Modify]. From the pop-up list pick Delete.  

  A warning dialog appears requiring you to confirm that you wish to 
delete the category and all its items. 

  Pick [Yes] or [No], as appropriate 
 
Deleting a specification category WILL delete all items associated with the selected 
category 

 
Removing a Specification Category Item 
 
  Under the Specification list (left-hand side window) pick the category 

containing the item you wish to delete. The edit window on the right-hand 

side will un-grey.  

  Pick the item you wish to delete from the list and pick [Modify]. From 
the pop-up list pick Delete.  

  A warning dialog appears requiring you to confirm that you wish to 
delete the item. 

  Pick [Yes] or [No], as appropriate 
 
 
 

Datatype 
Manager 

 

The prefixes and suffixes for the data KeySCAPE defines in the drawing 
Specification and Schedules can be modified using the new Datatype Manager, e.g. 
rather than have the prefix Plot, if you prefer plots to be defined by the prefix Ref: 
KSC (so plots will now be referenced Ref: KSC1, Ref: KSC2, Ref: KSC3) you can 
change this as follows: 

 
To Modify the Prefix or Suffix of data defined by KeySCAPE  
 

  From the Core pulldown, select Datatype Manager. The Datatype 

Manager dialog appears. 
 

        
 

  Select the group you wish to define or modify the prefix/suffix and then 
select the data field you wish to modify, e.g. to modify plots, expand the 
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General group then select Plot from the list 
  Modify the Prefix from “Plot” to “Ref: KSC”. This will insert the word “Ref: 

KSC” before any plot number rather than the current default “Plot”. 

 

       
 

  Pick OK. When using plots in this drawing, the prefix for a plot will now 
be Ref: KSC not Plot 

  Modify other datatypes, as required       
 
 

Price List 

Manager 

Price Lists are NOT stored as a generic price list on a KeySCAPE database 

but are defined and saved in individual drawings. You can assign prices to any 
plant specification defined in the drawing. The price you define is for your own 
budgetary purposes only so you can enter the price that is most appropriate to your 
needs, e.g. supply only, supply and plant only or prepare, supply, plant and 
maintain for twelve months. See Plant Lists earlier in this section for more 
information on how to assign prices to plant specifications in a plant list(s). 
 
 
Assigning Prices to Specifications in the Drawing  
 

  Continue from the previous section with a drawing that contains plant 
specification information or open the read-only drawing 
KSTBase05.dwg. 

  From the Softworks menu, select Price List Manager.  The Price List 
Manager dialog appears and displays all the plant specifications 
currently in the drawing. 
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  For each plant specification currently defined in the drawing, enter an 
appropriate price. 

  Pick [OK] to apply the price changes 
 
The currency symbol used can be modified from the Core menu, Datatype 
Manager, Pricing section. See earlier in this section for modifying the suffixes and 
prefixes of data displayed in the drawing. 

 
 
Managing Price Lists  
 
You can change the price assigned to a specification in the drawing individually, 
globally or export and import for use on other drawings. 

 

  From the Softworks menu, select Price List Manager.  The Price List 

Manager dialog appears and displays all the plant specifications 
currently in the drawing.. 

 
Modifying a Plant Specification Price 
 

  To modify a single price, select the plant specification from the list and 
modify the price. 

  To change the prices of all plants in the drawing, pick [Global 
Update]. The Price List – Global Update dialog appears.          

  Under Type, define how you wish to modify all the prices in the 
drawing. This will set whether the value entered is a percentage or an actual 

unit of currency. 

  Select Percentage to enter a percentage value change 
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  Select Amount to enter an actual currency value change 
 

                   
 

  Under Direction, select either Increase or Decrease to define how 
you wish to modify all the prices in the drawing. 

  Pick [OK] to apply the defined price changes to all the plant 
specifications in the drawing. 

 
 
Saving and Re-using Price Lists 
 

Price lists are saved in the current drawing only. As such, if you copy and paste a 
planting object (specification) from one drawing to another the price does not copy 
with the speciation. However, you can export (save) a price list for use on other 
drawings using the import functionality. 

 

  From the Softworks menu, select Price List Manager.  The Price List 
Manager dialog appears. 

  To save the current price list for use on another drawing, pick Export. 

The Export Price List dialog appears. 
 



Key Systems Advanced Softworks Features 

 

KeySCAPE Design Studio Tutorial 
SCAPE Section3Rev5 

.DOC Revision0       3-45 
 

       
 

  Navigate to where you wish to save your price list file, enter the file 
name and pick [Save] to save the file. The KeySCAPE price list will be 
saved with a “.kpl” file extension. 

  To use the price list on another drawing, use the [Import] function to 
open and import a saved “.kpl” file. 

 
If prices are already assigned to plant specifications currently defined in the 
drawing (i.e. they have a non-zero price), for each plant you will be asked to tell 
KeySCAPE whether you wish to keep the current drawing price or overwrite this 
with the new, imported price. 

 

        
 

  Select the option as appropriate to your requirement, as follows: 
 
[Yes] – to overwrite the current price and move to the next record 
[Yes To All] – to overwrite all current prices in the drawing and add 
prices to specifications that currently have no price assigned. 
[No] – to keep the current drawing price and move to the next record 

[No To All] – to keep all the current drawing prices and only add 
prices to specifications that currently have no price assigned. 
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Purging Prices for Specifications No Longer Used in the Drawing 
 
An imported price list file may contain specifications and prices for plants not 
currently used in the drawing. This may be desirable as you may wish to import the 
price list before you start labelling the drawing so that the prices are already 
defined. Inevitably, you will import more plant prices than specifications currently 
used in the drawing and may wish to remove these unused specifications and 
prices. Also, as you modify or delete planting objects from the drawing the original 
specification will still appear in the Price List Manager dialog even though it may no 
longer exist in the drawing..  
 

  To remove unused specifications from the drawing, in the Price List 

Manager dialog, pick [Purge]. You will be prompted to confirm that 
you wish to remove any unused (redundant) specifications.  

 

       
 

  Pick {Yes] to remove the unused specifications or [No] to cancel the 
removal and return to the dialog. 

 
 
Resolving Price Conflicts (Plant Lists/Modify Specifications) 
 

A plant specification in a plant list can have a price assigned to it. It is possible that 
a plant speciation may appear in several plant lists with different prices assigned to 
it (for instance based on different tender prices) or the plant has been allocated a 
price manually via the Price List Manager.  

 

  When you modify a plant from the Modify dialog or globally using 
Modify Specifications, if you select the same (identical) plant 
specification from a differently priced plant list, you will be notified of 
any price conflict. 

 

        
 

  Pick [Yes] to use the new price from the plant list or [No] to keep the 
currently defined drawing price. 

 
Prices can be displayed in the drawing as both Unit Cost and Total Cost. This can 

be shown on the plant label or in the drawing schedule using the Specification 

Style and Schedule Style respectively. See Specification Styles and Schedule 
Styles later in this section for more information.  

. 
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Specification 
Styles 

Styles allow you to define or redefine the display of specification information in the 
drawing. 
 
Styles are a common means of displaying and modifying the appearance of an 
AutoCAD object in the drawing. You will be familiar with some of these using 
general AutoCAD, e.g. Text Styles, Dimension Styles, Plot Styles, etc. 
 
Autodesk has extended this functionality to control the display of objects in their 
own applications, such as Architecture, Map 3D, Civil Design. Styles allow you to 
quickly modify aspects of the object (or its display) and see the immediate effect of 
the change, not only to the main object but also to all "linked" objects, thus 
speeding up modifications to the drawing and the consideration of design options. 
 
KeySCAPE uses Styles to control how information in a specification label or 
schedule is displayed. Drawing Setup (Core) allows you to create and define the 
default styles before you start drawing but you have the flexibility to create new 
styles and modify existing ones as you start designing. 
 
 

Modify the Appearance of Plant Specification Text 
 
Also refer to Section 2: “Modifying a Specification – Specimen” for information 
regarding changing the Specification text font, height, angle (rotation) and 
redefining the specification leader.  

 

  From the Softworks pulldown, select Specification Display>Styles. 

The Specification Style dialog appears. 
 

   
 
You can also access the specification styles from Core>Drawing 

Setup>Softworks Styles (tab)>Specification Style>  

 
 
You can modify the current style as follows: 
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  Style Name – drop down list showing the Specification Styles 
available in the current drawing. The default style, KeySOFTWORKS 
Standard will be created with every new drawing opened with 
KeySCAPE 

  [Rename...] - allows you to rename the currently selected Style 

  [Copy Existing...] - allows you to make a copy of the currently 
selected Style and edit the display specification information so the 
original style remains unedited. 

  [Delete...] - allows you to delete the currently selected Style from the 
drawing. You will not be able to delete a style if it is being used in the 
drawing 

  [Import...] & [Export...] - Specification Styles can be exported and 
imported as *.kis files. This provides the facility to export styles defined 
in one KeySCAPE drawing to import in to another KeySCAPE drawing. 
If these files are held on a network, or shared drive, they can be used 
by several users, as required.  

 
The default KeySOFTWORKS Standard style will be created with every drawing 
opened in KeySCAPE. If you wish to define your own default template, modify and 
export your preferred style overwriting the KeySOFTWORKS Standard.kis file. It is 
recommended that you make a copy of the original file before overwriting it as you 
may wish to restore the default installed style in the future. 

 
 

General / Leader properties tab 
Allows you to make general changes to the display of the entire 
specification and leader, including: the Border Type, Border Colour and 
Border Background Colour 
 

        
 

 

  Leader - allows you to specify the appearance of the leader, including: 
Point Type – this has a default of Blob but can be set to Triangle 
or Arrow 

Point Scale – adjustment of the text scale 
Colour - allows you to define the colour of the leader, as by 
default, the leader will take on the colour of the layer on which the 
object is inserted. 

Lineweight - the full range of AutoCAD lineweights can be used 
Show Header At Leader Points – allows you to replace leader 
points with header text defined within the specification of the plant. 

[Set End Point]  - opens the Leader End Point Select dialog that 
allows you to define the Autoleader properties. 
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The Leader End Point dialog allows you to set the default attachment point for the 
auto leader function. When using this function you draw the leader from the object 
and it is automatically completed back to the specification text to the point on the 
specification defined within the above dialog. The default setting is No Attachment, 
i.e. Autoleader if turned off. Draw Extension allows you to draw a small landing line 
back to the text when using the outer anchor points. 

 

Default Cell properties tab  
Allows you to define the default properties of all the cells  
      

 
 

  Text - allows you to specify the text settings for the currently selected 
Style, including: 

 
Style - pick from the list of current (AutoCAD) Text Styles defined in 
the drawing 

Height - specify the height of the text relative to the current 
drawing units (m, mm or inches) 

Colour - select the preferred colour for the text as, by default, the 
text will take on the colour of the layer on which the specification is 
inserted 
Justification - defines whether the specification text is justified 
left, right or centred about the picked insertion point 
Precision - defines the number of decimal points displayed for 
number calculations 
Alignment – the text can be aligned from the top, middle or 
bottom 
 

  Border - allows you to specify the cell border settings for the currently 
selected Style, including: 

Border Type - defines whether the cells are boxed, underlined or 
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whether no border is drawn 

Background Colour – defines the background colour of the cell 
Border Colour – select the preferred colour for the border as, by 
default, the text will take on the colour of the layer on which the 
specification is inserted 

Cell Fixed Width – by default cell widths are set to Variable so 
that the width is defined by the data displayed in the cell. You can 
set a default value for all cells so that columns “line-up”. In this 
instance, text will automatically wrap if the contents exceed the cell 
width.  
 
N.B. As AutoCAD does not support hyphenation of text during text 
wrapping (Mtext), if a single word is longer than the cell width, the text will 
extend beyond the cell border and overlap adjacent cells 

 

Selected Cell Properties Tab 
Allows the properties of a selected cell to be specified individually so that 
its properties can differ from that defined by the style defaults (see above 

section for definitions) 
 

 
 
 

Softworks Specification (drop down) – allows you to define the display of 
softworks specific information (e.g. Species, Height, Mix Name, etc.) contained 
within the Softworks Specification. 
        

 
[Insert] -allows you to add the selected specification data, chosen from 
the associated drop-down list, to a selected cell. This cell must be "active" 
(selected) to insert the data 
 
You can select a currently occupied cell when inserting new data into the grid. If 
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you do this you will be asked if you wish to Overwrite the current cell or shift the 
current cell to the right or down.  

 

  Measurement (drop down) - allows you to add to the style display the 
Area, Length, Number and Perimeter of the object 

 
 
N.B. Measurement calculations only display in major units, i.e. m for m or mm 
drawings and ft for inches and feet drawings 

 
 
 

 
 
 

  General (drop down) - allows you to choose between Object Type (for 
example, planting area) or Plot number. 

 

 

   Remove Data - select the specification item you wish to remove 
and pick the delete button from the navigation bar 

 

  Navigation Buttons - use the appropriate buttons to define/redefine 
the position of a selected specification item within the grid, and thus its 
eventual display location in the drawing 

 

                          
 

  Pick [Yes] to accept the changes or [No] to cancel the command. If 
you pick yes, the appearance of the tags will change after a short time. 

 

Standard Specification Styles 
 
To help with the creation of specification styles, KeySCAPE includes several 
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predefined styles. These can be imported in to the drawing from the styles folder 
and can be modified or used as a template for the creation of new styles. 

 
Assigning Specification Styles 
 
When inserting a specification in the drawing the information will display according 
to the current style. However, you can have any number of styles available in a 
drawing and assign different styles to selected specifications, as required. You can 
assign a style to a specification, as follows: 
 

  From the Softworks pulldown, select Specification Display>Set 

Style. You are returned to the drawing and prompted, at the command 
line, to Select objects: 

  Select the specifications you wish to assign a different style.  

  When all required specifications are selected, press Return. The Set 

Style dialog will appear. 
 

        
 

  From the dropdown list, pick the specifications style you wish to apply 
to the selected specifications.  

  Pick [OK] to assign the style.  
 
 
 

Schedules 

Styles 
 

The display of the Schedule is now defined using Styles. You can create and define 
the default style(s) used to display a schedule before you start drawing but you 
have the flexibility to create new styles and modify existing ones as you start 
designing. 

 

To Modify the Appearance of a Schedule  
 

  From the Softworks pulldown, select Schedule Display>Styles. The 

Specification Style dialog appears. 
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You can also access schedule styles from Core>Drawing Setup>Softworks 

Styles (tab)>Schedule Style>  
 

You can modify the current style as follows: 
 

  Style Name – drop down list showing the Schedule Styles available in 
the current drawing. The default style, KeySOFTWORKS Standard will 
be created with every new drawing opened with KeySCAPE 

  [Rename...] - allows you to rename the currently selected Style 

  [Copy Existing...] - allows you to make a copy of the currently 
selected Style and edit the display specification information so the 
original style remains unedited. 

  [Delete...] - allows you to delete the currently selected Style from the 
drawing. You will not be able to delete a style if it is being used in the 
drawing 

   [Import...] & [Export...] - Schedule Styles can be exported and 
imported as *.kss files. This provides the facility to export styles 
defined in one KeySCAPE drawing to import in another KeySCAPE 
drawing. If these files are held on a network, or shared drive, they can 
be used by several users, as required.  

 
The default KeySOFTWORKS Standard style will be created with every drawing 
opened with KeySCAPE. If you wish to define your own default template, modify 
and export your preferred style overwriting the KeySOFTWORKS Standard.kss file. 
It is recommended that you make a copy of the original file before overwriting it in 
case you need to restore the default installed style in the future. 
 

  Schedule Contents -allows you to specify the information to be 
displayed in the currently selected Style. This is controlled by the 
creation and modification of Groups (headings), that include Columns 
that define the information required to describe the object. In this way 
you can create different schedules that only show specific information, 
e.g. schedule only Tree information 
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Defining schedule Groups and Columns 
       

 
 
Construction of a Schedule 
 
[Add Group...] - Adds a new blank group to the schedule style at the 
bottom of the grid. The properties of the group can be edited in the 
schedule Group Properties (tab). 

       

 
 

  Header - the name of the group. This is what will appear in the 
“header” of the group when it appears in the schedule, e.g. Trees 

    Sub Group by Plot - allows you to group the schedule using the 
plot definitions 

    Group by Object Type - allows you to filter the schedule 
information by an object type, including:!

!
ON - you can group the required information based on: 
 
Specimens - will filter for only specimen information that meets the 
specified criteria 
Hedges - will filter for only hedge information that meets the specified 
criteria 
Planting Areas - will filter for only planting area information that meets 
the specified criteria 
 
<None>  - will not filter for Softworks types in the schedule 

!
    Group by Specification - allows you to filter the schedule so the 

group will only show data based on the specification information 
defined for KeySCAPE objects (Trees, Shrubs, etc), e.g. species group, 

abbreviation, density etc., including:!
 

  [Append Column...] - creates a new column within a selected group 
for the existing Style. To create a new column select an existing cell, 
select the type of data to be inserted from the drop down menu (e.g. 
Measurement, Softworks specification…) and from the next drop menu 
down select the specific data (e.g. Pot size), then pick Append 
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Column to insert the data. 
 

       
 

$  Total This Column - will total the contents of the column where the 
data is a numeric value, e.g. plant numbers, areas. Select the column to be 

totalled and the Schedule Column Properties (tab) will appear. Check the Total 
This Column (box) 

 

   Remove Data - select the specification item you wish to remove 
and pick the delete button from the navigation bar 

 

  Navigation Buttons - use the appropriate buttons to define/redefine 
the position of a selected specification item within the grid, and thus its 
eventual display location in the drawing 

 

                          
 
Moving an item up or down the style list affects the order the information will appear 
in the schedule, namely: 
 

  Groups - the order that the groups are arranged in the style list defines the 
order the groups will appear in the schedule, top to bottom, when inserted in 
the drawing, e.g. if the style list of groups is in the order: Trees, Conifers and 
Shrubs, they will appear in the drawing in the order, top to bottom: Trees, 
Conifers and Shrubs 

  Columns - the order that the columns are arranged in the style list, top to 
bottom, defines the position the column will appear within the schedule, left to 
right, i.e. moving a column higher up the list moves its position within the 
schedule further to the left whilst moving it down the list moves its position 
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further to right, e.g. 
 

        
 

  Header - Text - enter the text you wish to appear as the main schedule 
name, e.g. Plant Schedule 

 

      
 

  Default Cell Properties (tab) - allows you to specify the text settings 
for each part of the schedule, including: 

 

       
 

Style - pick from the list of current (AutoCAD) Text Styles defined in the 
drawing 

Height - specify the height of the text relative to the current drawing 
units (m, mm or inches) 
Colour - select the preferred colour for the text as, by default, the text 
will use the colour of the layer on which the schedule is inserted 
Border - specify whether the text is either: Boxed (has a frame), Not 
boxed (has no frame), or Underlined 
Justification - functionality not currently supported 

Alignment - functionality not currently supported 
 
 
Standard Schedule Styles 
 
To help with the creation of schedule styles, KeySCAPE includes several 
predefined styles. These can be imported in to the drawing from the styles folder 
and can be modified or used as a template for the creation of new styles. 

 
Assigning Specification Styles 
 
When inserting a schedule in the drawing the information will display according to 
the current style. However, you can have any number of styles available in a 
drawing and assign different styles to different schedules, as required. You can 
assign a style to a schedule, as follows: 
 

  From the Softworks pulldown, select Schedule Display>Modify/Set 
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Style. You are returned to the drawing and prompted at the command 
line to Select Schedule to modify:: 

  Select the schedule(s) you wish to assign a different style and press 
Return. The Modify Schedule dialog will appear. 

 

        
 

  Select the schedule style you wish to use from the dropdown list or 

pick  to create new and/or modify an existing Style 

  Pick [OK] to assign the style to the selected schedule(s).  
 

 
 

Plot 
Schedules  

You may wish to assign plot numbers to plants in the drawing and insert a schedule 
based on these plot numbers, i.e. to show all plants assigned to a specific plot. This 
can be useful for housing developments or phased drawings.  
 
N.B. The prefix KeySCAPE uses for plots is Plot, e.g. Plot 1, Plot 2, etc. If you 
would prefer either no prefix or your own, say Ref: KSC, you can modify this though 

Core>Datatype Manager. See earlier in this section for more information,  

 
Assigning Plot Numbers 
 
You can assign Plot Numbers in two ways: 

 
Adding or Modifying a Softworks Object 
 
When you add or modify a specimen, hedge or planting area you can assign the 
plot number with the specification, as follows (for a Planting Area):  

 
  From the Softworks menu, select Planting Area>Add or Modify (if 

modifying an existing planting area). The Planting Area dialog appears. 
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  Define the Planting Area as detailed in Section 2 to assign the required 
graphics and appropriate specification. 

  In the edit window adjacent to Plot Number, enter the plot number or 
reference you wish to assign to the planting bed, e.g. 1 (for plot number 

1), or PN01 (plot number 01), or similar. 

  Pick [OK] to apply the plot reference/number to the planting bed. 

  Repeat the above to assign new or reallocate plot numbers/ 
references to other planting objects. 

 
 

Applying Globally to Softworks Objects 
 
This can be most useful when you have several specimens, hedges or planting 
areas in the drawing and you wish to quickly assign plot numbers to multiple 
softworks objects without modifying the objects individually. 
 

  From the Softworks menu, select Specification Display>Set Plot. 
  You are returned to the drawing and prompted to Select objects.  
  Pick the softworks object(s) (specimens, hedges and planting areas) to 

which you wish to assign a plot number or reference. 
  When selected, press Return. The Set Plot Dialog appears. 
 

       
 

  Enter the plot number or reference you wish to assign to the selected 
softworks objects, e.g. 1 (for plot number 1), or PN01 (plot number 01), or 

similar. 

  Pick [OK] to apply the plot reference/number to the selected softworks 
objects. 

  Repeat the above to assign new or reallocate plot numbers or 
references, to other softworks objects in the drawing. 
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Inserting a Plot Schedule 
 
Plot schedules are full schedules but have a filter applied to them so that they 
group plants based on their plot number. To assist with the creation of plot 
schedules, KeySCAPE includes a default plot schedule style that can be imported 
and modified, as required. 
 

  From the Softworks pulldown, select Insert Schedule. The Add 

Schedule dialog will appear. 
 

        

 

  Next to the schedule style dropdown list, pick . The Schedule Style 
dialog appears. 

      

 
 

  Pick [Import]. The Import Schedule Style dialog appears, and 
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defaults to the KeySCAPE Softworks Styles folder. 
 

        
 

  From the list pick the schedule style KeySOFTWORKS Plot.kss - the 

default style installed with KeySCAPE for scheduling plots 

  Pick [Open] to return to the Schedule Style dialog.  

  Pick [Apply] to apply the change and [Close] to return to the Add 
Schedule dialog. 

  From the schedule style dropdown list, pick. The KeySOFTWORKS 

Plot Style. 

  Next to Header, enter the text you wish to appear as the header to 
your schedule, e.g. Plot Schedule 

  Pick [OK]. You will be returned to the drawing and prompted to pick a 

Schedule Location: 

  Pick the point where you wish the schedule to appear, based on the 

top left-hand corner of the schedule frame. The schedule will be 
displayed in the drawing. 
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Plants with no allocated plot number or reference will appear in the schedule under 
the group “No Plot”. 
 

  As you assign or reassign plot numbers/references to softworks 
objects in the drawing (see previous section) the plants will automatically 
move between plot groups, as appropriate. 

 
Modifying a Plot Schedule 
 

Plot schedules are no different to full schedules and their display can be modified 
as described for Schedule Styles, earlier within this section, and full schedules 
defined in Section 2:  Plant Schedules 
 
 

Exporting 
Project 

Schedules 
 

Project Schedule allows you to select a number of open or selected drawings to 
export as a combined file (project schedule) in a .CSV (comma separated value 
*.csv) text file. This file can be opened in a range of software, including MS Excel, 
MS Word, or MS Access. 
 

  From the Soft pulldown, select Schedule>Project Schedule. The 
Project Schedule dialog appears. 
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  Style - allows you to select a schedule style currently referenced in the 
active drawing to define the information and format of the data to be 

exported. Pick  to select an alternative style file. 

  Header - allows you to add text that will appear as a header to the 
exported schedule 

  Currently Open Drawings - allows you to select any number of 
currently open drawings to include with the project export. 

 
The drawings listed will include the current drawing and any other drawing opened 
in the background. It will always list the latest version of any drawing file so if an 
autosave has been performed on a drawing since it was last active, the drawing list 
will include the autosave version. These files will have a .SV$ file extension. 

 

  Use [Select ->] to either select or clear all selection 

  Additional Drawings - allows you to add or remove additional 
drawings to include with the project export 

  [Add] –allows you to browse to an select additional drawing files to 
include within the project export 

  [Remove] - allows you to remove the currently selected drawing from 
the list of additional drawings. 
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  Export File - allows you to define the file name for the export file.  

  Pick  to define the folder where you wish the export file to be saved. 

  Pick OK to complete the export of all of the selected drawing file.  
 
Project schedules are exported as a .CSV (comma separated value *.csv) text file. 
This text file can be opened in a range of software but usually requires you to set 
the Files of Type within the Open dialog to Text Files (*.txt, *.csv). 
 
 
 

Distributing 
KeySCAPE 

Drawings 

 

KeySCAPE uses the latest AutoCAD-based, object-orientated design. Like 
Autodesk’s own applications for Architecture, Mechanical and Civil design, 
KeySCAPE creates intelligent AutoCAD objects that are visible, but will not be 
editable, in general AutoCAD. AutoCAD will usually show these objects using 
simplified proxy (image) graphics that will not be editable in AutoCAD unless you 
install the KeySCAPE object enablers for your version of AutoCAD. Depending on 
your AutoCAD settings, the proxy entities may display as bounding boxes or may 
not show them at all. See sections below for more information. 
 

Sending KeySCAPE Drawings to AutoCAD Users 
 
Please follow the following procedures to ensure you save a drawing correctly 
BEFORE sending it to AutoCAD: 
 

  Open the drawing to be sent to the AutoCAD user 

  At the command line enter PROXYGRAPHICS and press Return. The 
default value of the AutoCAD system variable should be 1. If it is set to 
0, enter 1 and press Return. The current versions of KeySCAPE should set 

this automatically to 1 for you. 
 
The AutoCAD PROXYGRAPHICS system variable specifies whether images of 
proxy objects are saved in the drawing or not. If set to 1 the drawing saves the 
proxy graphic images so that they are available to display in AutoCAD. If set to 0, 
the proxy graphics images are NOT saved with the drawing and so, when opened 
in AutoCAD, KeySCAPE objects may not display or appear as bounding boxes. 
 

  At the command line enter ISAVEPERCENT and press Return. The 
default value of the AutoCAD system variable should be 50, although 
not necessarily. 

 
The AutoCAD ISAVEPERCENT (Incremental Save Percentage) system variable is 
a global setting (i.e. affects all drawings) that sets the percentage of potentially 
wasted space in a drawing file. If the Incremental Save Percentage is set to 0, 
every save is a full save. Full saves eliminates wasted space and can reduce 
drawing size but the performance of the SAVE and SAVEAS commands will slow 
significantly. Incremental saves are faster but they increase the size of your 
drawing as it includes wasted space. For optimum performance AutoCAD sets the 
default value to 50. That is, if less than half the drawing is modified between saves 
the change only information is appended to the drawing database. Conversely, if 
more than half the drawing is altered between saves, a full save is invoked.  

 

  At the prompt: Enter new value for ISAVEPERCENT, enter 0 and 
press Return 

  Save the drawing. This will invoke a full save of the drawing. 

  At the command line enter ISAVEPERCENT and press Return.  

  Enter 50 (or your previous value setting) and press Return 

  Close the drawing  

  Send your drawing to your client or design partner 
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Opening KeySCAPE Drawings in AutoCAD 
 
Please advise your clients or design partner of the following procedures BEFORE 
they attempt to open a KeySCAPE drawing in AutoCAD 
 

  When the AutoCAD user opens the drawing in AutoCAD the Proxy 
Information dialog should appear 

 

       
 

  Select the option Show proxy graphics and pick [OK] to open the 
drawing and display the KeySCAPE objects 

 
What to do if the Proxy Information dialog does not appear AND the 
KeySCAPE graphics do not show 
 
In this instance it is likely that the AutoCAD settings that control these options have 
been set to not display the Proxy Information dialog or, more importantly, to not 
show the proxy graphics. In this instance: 

 
  With the drawing closed, at the command line enter PROXYSHOW 

and press Return. The current value of the AutoCAD system variable 
is displayed and is most likely to be set to 0, i.e. to not show proxy objects 

  At the prompt: Enter new value for PROXYSHOW, enter 1 (to show 

proxy objects) and press Return 
 
The AutoCAD PROXYSHOW system variable is a global setting (i.e. affects all 
drawings) that controls the display of proxy objects in an AutoCAD drawing where 
the application that created the objects is not available. The following options exist: 

0 Proxy objects are not displayed 
1 Graphic images are displayed for all proxy objects 
2 Only the bounding box is displayed for all proxy objects 

 

  Open the KeySCAPE drawing in AutoCAD and all the graphics will 
show as image entities only, i.e. not editable as AutoCAD objects 

 
 
Object Enablers 
If a drawing is opened with proxy graphics showing you will only have access to 
limited editing features on the object, e.g. delete. However, should you wish to 
undertake more detailed editing, you can request and install the KeySCAPE Object 
Enablers for your version of AutoCAD. Once installed, this will give limited access 
to the objects and allow you to use most of the AutoCAD editing commands on 
KeySCAPE objects, e.g. copy, move, rotate, grips etc. However, it does not allow 
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any access to the KeySCAPE user interface to edit settings, specifications or 
planting/hedge graphics. This information can only be edited in KeySCAPE. Any 
changes made in a KeySCAPE (object) enabled AutoCAD will be updated next 
time the drawing is opened in KeySCAPE. 
 

SaveAs to earlier version of AutoCAD 
Due to limitations imposed by Autodesk on objects, any KeySCAPE drawing that is 
created or opened and saved in a newer version of AutoCAD, will not be editable 
in versions of KeySCAPE running on earlier versions of AutoCAD, even though the 
KeySCAPE functionality may be identical, i.e. there is NO backward compatibility 
between AutoCAD/KeySCAPE objects This also applies to the use of KeySCAPE 
enabled versions of AutoCAD. There is no work round to this! 
 

 
 

Exploding 
KeySCAPE 

Objects 

 

 

 

Limitations, imposed by Autodesk on custom objects prevent the use of DXFOUT 
and DXFIN unless the objects are exploded to simple drawing entities. These 
simplified versions of the objects have no intelligence but allow them to be edited in 
AutoCAD or other applications, such as SketchUp, Adobe Illustrator or CorelDRAW  
 

To Explode the KeySCAPE objects  
 

  Go to Core>Explode KeySCAPE Objects  

  At the command line you are prompted to Select objects: 

  Select the KeySCAPE objects you wish to explode or type ALL to 
select all the KeySCAPE objects in the drawing 

  Press Return to complete the command 

  All the former KeySCAPE objects will now be exploded to simple, 
unlinked AutoCAD entities 

 
N.B. If you explode KeySCAPE objects all links are destroyed. As such, if you 
explode a specification BEFORE you explode the schedule(s) plants WILL 
disappear from the schedule. As such, either explode the schedule BEFORE you 
explode the specifications or make sure you explode both at the same time by 
using a window selection or type ALL to select all the KeySCAPE objects. 

 
Alternatively, you can explode KeySCAPE objects using the AutoCAD Explode 
Command. However, you will need to explode the objects twice to get back to 
single AutoCAD entities. Please note that the following default results: 
 
First use of the AutoCAD Explode Command on KeySCAPE objects – 
explodes each object into individual AutoCAD blocks, i.e. one new block is created 
for each object. 
 

Second use of the AutoCAD Explode Command on KeySCAPE objects – 
explodes each individual AutoCAD block, derived from the objects, into single 
editable AutoCAD entities.  
 

IMPORTANT: Exploding the KeySCAPE objects WILL destroy all object 
functionality and associated intelligence, e.g. automatic update of plant number 
calculations and schedules. Once the drawing has been closed, the links can NOT 
be recreated automatically. Therefore, it is strongly recommended that you make a 
backup of the drawing (SaveAs) BEFORE exploding the objects. After exploding 
the drawing, your drawing size may increase considerably. 
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